Closed Bug 1095643 Opened 5 years ago Closed 5 years ago

Show site identity when mixed content is blocked

Categories

(Firefox for Android :: General, defect)

35 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 36
Tracking Status
fennec 37+ ---

People

(Reporter: Margaret, Assigned: Margaret)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

I think this is a regression from bug 966866 (or really from bug 945212, but we didn't handle fixing this correctly).

I believe we should still show the site identity information when mixed content is *blocked*, since in that case all the content on the page is in fact coming from the verified domain.
tracking-fennec: --- → ?
tracking-fennec: ? → 37+
Assignee: nobody → margaret.leibovic
Blocks: 1102539
I'm fixing the regression here by making sure we show site identity information if mixed content is blocked. However, I filed bug 1102539 as a follow-up to come up with a better solution here that would allow us to always show the site identity information.
Attachment #8526378 - Flags: review?(michael.l.comella)
Comment on attachment 8526378 [details] [diff] [review]
Only hide site identity info if mixed content is loaded

Review of attachment 8526378 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/toolbar/SiteIdentityPopup.java
@@ +96,2 @@
>          final MixedMode mixedMode = siteIdentity.getMixedMode();
> +        if (mixedMode == MixedMode.MIXED_CONTENT_LOADED) {

After looking into some potential solutions for bug 1102539, I'm tempted to just remove all of this logic and always show the site identity data, since we will be showing the "unknown identity" in the case of loaded mixed content. While "unknown" isn't exactly true in this case, it prevents the user from thinking they're on a secure page when they're not.

And if we always show this "unknown identity" here, we'll avoid the weird UI issue of the darker notification with no light information above it.
(In reply to :Margaret Leibovic from comment #2)

> After looking into some potential solutions for bug 1102539, I'm tempted to
> just remove all of this logic and always show the site identity data, since
> we will be showing the "unknown identity" in the case of loaded mixed
> content. While "unknown" isn't exactly true in this case, it prevents the
> user from thinking they're on a secure page when they're not.
> 
> And if we always show this "unknown identity" here, we'll avoid the weird UI
> issue of the darker notification with no light information above it.

Sounds like a good idea to me. Let's live with it and see how it feels. I think it will help us get a forward direction.
Changing the approach here based on previous comments.
Attachment #8526378 - Attachment is obsolete: true
Attachment #8526378 - Flags: review?(michael.l.comella)
Attachment #8526483 - Flags: review?(michael.l.comella)
Attachment #8526483 - Flags: review?(michael.l.comella) → review+
https://hg.mozilla.org/mozilla-central/rev/b1fe09f763e2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Blocks: site-id-v2
No longer blocks: 1102539
You need to log in before you can comment on or make changes to this bug.