libflashplayer.so causes total stall of firefox - system activity dropped to nearly all idle

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
major
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Pierre Fortin, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141107030202

Steps to reproduce:

- restarted with latest nightly (10 windows with MANY tabs/pages each)
- read some tabs (slashdot, drudge, breitbart)
- when I switched to the theblaze.com tab, page came up, started scroll and FF locked up
- switching to other windows ( I have KDE setup to group all FF windows), each was blank, including the on that stalled when I returned to it

This was the first time for this sort of problem -- no idea how to reproduce --  reporting it in case it re-occurs...



Actual results:

lockup/stall

$ strace -p 16180
Process 16180 attached
futex(0x7fb9b568280c, FUTEX_WAIT_PRIVATE, 382541, NULL
^CProcess 16180 detached
 <detached ...>
$ strace -p 16292
Process 16292 attached
futex(0x7f175af373cc, FUTEX_WAIT_PRIVATE, 43, NULL
^CProcess 16292 detached
 <detached ...>
 $ strace -p 32365
Process 32365 attached
futex(0x7f7bbebd5e8c, FUTEX_WAIT_PRIVATE, 9, NULL
^CProcess 32365 detached
 <detached ...>

so I killed FF & restarted.


Expected results:

keep running
(Reporter)

Comment 1

3 years ago
Reproducible, though not sure what triggers it... bumping severity to major because it's unacceptable to have to restart every few minutes.

Get this on the konsole when it happens:

$ 1415392009064        addons.update-checker   WARN    Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property

** (plugin-container:3033): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed
2014-11-07 15:45:03: stackwalker.cc:125: INFO: Couldn't load symbols for: /lib64/libpthread.so.0|18362EE5DFDF5B8298287819837C8E620
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64d9ce2f08
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64d9c99d70
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x58466
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f069c0
2014-11-07 15:45:03: stackwalker.cc:125: INFO: Couldn't load symbols for: /home/usrlocal/bin/firefox36.0a1/libnspr4.so|88FE41C53D2192472A6A83E068DA78F00
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06b70
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0xffffffff
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64d9b53760
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x42213526
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f069e0
2014-11-07 15:45:03: stackwalker.cc:125: INFO: Couldn't load symbols for: /home/usrlocal/bin/firefox36.0a1/libxul.so|4E8733FA7C513B54DC1FBF9ADD342FCD0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f652647d060
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0xffffffff
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06a10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x1
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f652647d060
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06a40
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06a58
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06ad0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06a70
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x14
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06a58
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-07 15:45:03: stackwalker.cc:125: INFO: Couldn't load symbols for: |
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06b40
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06af0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06ad0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06ab0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x80
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c18
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f652647d060
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06c00
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06c00
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06b40
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff00000000
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06b70
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f652647d060
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64d9b53760
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e36c3680
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f65264055f8
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7f64e04b4c10
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06cc0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06cf0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06bd0
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06be8
2014-11-07 15:45:03: basic_code_modules.cc:88: INFO: No module at 0x7fff05f06c30

When killing FF, I get:

[24643] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-l64-ntly-000000000000000/build/ipc/glue/MessageChannel.cpp, line 1492
[24643] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-l64-ntly-000000000000000/build/ipc/glue/MessageChannel.cpp, line 1492
/usr/local/bin/ff: line 118:  2458 Killed                  ${USRLOCAL}/firefox/firefox

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv


###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv


[14]+  Exit 137                ff
Severity: normal → major
(Reporter)

Comment 2

3 years ago
moved to Blocker because each restart is worse than the one before.  Totally unusable now...
I don't update every day, so this occurred between the 10/24 and the http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-36.0a1.en-US.linux-x86_64.tar.bz2 version as downloaded at 16:26 EST on 11/07/14.
Severity: major → blocker
(Reporter)

Comment 3

3 years ago
Created attachment 8519255 [details]
FFbug1095683.jpg

Note that KDE reports that 10 windows should be open; but only 2 are visible in the group (title bar) -- for some reason, KDE is not grouping the remaining windows -- did a recent update change the title bar in a way to destroy grouping?

Whenever I go to another window, all I get is the spinner; have to switch to another tab and back to get contents -- this may be intended to minimize startup overhead; but FF should get the current page, not wait for the user to switch back into the active page.

Yeah, these comments should be new bug reports; but I'm more concerned with the hang/stall...
(Reporter)

Comment 4

3 years ago
Another konsole output:

!!! [SmartNamer] updateEntry(): undefined
!!! [SmartNamer] updateEntry(): undefined
!!! [SmartNamer] updateEntry(): undefined
!!! [SmartNamer] updateEntry(): undefined
!!! [SmartNamer] updateEntry(): undefined
!!! [Core] updateMenus(): TypeError: menu.window.content.document is undefined
!!! [SmartNamer] updateEntry(): undefined
2014-11-07 18:27:47: stackwalker.cc:125: INFO: Couldn't load symbols for: /lib64/libpthread.so.0|18362EE5DFDF5B8298287819837C8E620
2014-11-07 18:27:47: basic_code_modules.cc:88: INFO: No module at 0x0
........... and more of these.
(Reporter)

Comment 5

3 years ago
I doubt this is helpful; but in case...

$ ps aux | grep fire
pfortin   9262 44.0  3.9 2038032 639512 pts/1  Sl   18:31   0:40 /usr/local/bin/firefox/firefox
pfortin   9388 24.7  4.8 1247368 788516 pts/1  Sl   18:31   0:20 /home/usrlocal/bin/firefox36.0a1/plugin-container -greomni /home/usrlocal/bin/firefox36.0a1/omni.ja -appomni /home/usrlocal/bin/firefox36.0a1/browser/omni.ja -appdir /home/usrlocal/bin/firefox36.0a1/browser 9262 true tab
pfortin  10134  0.1  0.2 484100 35120 pts/1    Sl   18:32   0:00 /home/usrlocal/bin/firefox36.0a1/plugin-container /home/pfortin/.mozilla36.0a1/firefox/iowvrjx2.default-1404854812966/plugins/libflashplayer.so -greomni /home/usrlocal/bin/firefox36.0a1/omni.ja -appomni /home/usrlocal/bin/firefox36.0a1/browser/omni.ja -appdir /home/usrlocal/bin/firefox36.0a1/browser 9262 true plugin
(Reporter)

Comment 6

3 years ago
Created attachment 8519294 [details]
bug1095683.btfull

gdb "bt full" outputs from the 3 FF processes that are hung.
(Reporter)

Comment 7

3 years ago
(In reply to myself from comment #3)
> Note that KDE reports that 10 windows should be open; but only 2 are visible
> in the group (title bar) -- for some reason, KDE is not grouping the
> remaining windows -- did a recent update change the title bar in a way to
> destroy grouping?

After many restarts, they are being grouped again; but the hangs happen moments after startup.  Using a FF/Wine to update this report.
(Reporter)

Comment 8

3 years ago
Appears to be due to libflashplayer.so

Removing it stops the hangs; but now there's no way to play videos; even using "Video WithOut Flash 1.4.3".
Severity: blocker → major
Summary: total stall of firefox - system activity dropped to nearly all idle → libflashplayer.so causes total stall of firefox - system activity dropped to nearly all idle
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 9

3 years ago
36.0a1 (2014-11-24) seems to be OK with Flash again...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.