microsoft.com - MSDN has 1px hard-to-drag frameborder (different rendering from IE)

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: taf2, Unassigned)

Tracking

({top100, top500})

Details

(URL)

(Reporter)

Description

17 years ago
It seems a feature was removed.  If I recall older version of mozilla would 
allow viewers of msdn library pages the ablity to move the frame bars around
just like you can in I.E.  Perhaps this has something to do with how ms is 
writing there html pages.  At any rate could be a bug with mozilla so I figured
I should file a report.
Todd
Which frame bars are relevant here?  That is, what do you mean by "frame bars"?
OK, some investigation and mails back and forth with Todd show the following:

1)  The "frame bar" in question is the border between the table of contents
    frame on the bottom left and the content frame on the bottom right
2)  This frameborder is 1px wide in Mozilla, due to all the framesets setting
    'border="1" frameborder="1"' and the frames themselves doing the same.
3)  Todd can grab&drag this border fine on Linux but not on Win2k
4)  IE does _not_ render the border as 1px wide.  Todd says (my comments in
    square brackets):

----------------------------------
http://www.zbarsky.org:8000/~bzbarsky/frameset_msdn.html
can't grab the separator in this window
[this is the page as it is on the MSDN site]

I can grab the seperator in all the of the versions below
http://www.zbarsky.org:8000/~bzbarsky/frameset_2.html
http://www.zbarsky.org:8000/~bzbarsky/frameset_3.html
http://www.zbarsky.org:8000/~bzbarsky/frameset_4.html
http://www.zbarsky.org:8000/~bzbarsky/frameset_5.html
http://www.zbarsky.org:8000/~bzbarsky/frameset_6.html
[These are the same page with 2px,3px,4px,5px,6px border instead of 1px]

In IE the border is the same in all of the listed links above
and it looks most like the last url, however the seperator
in IE is still a little larger.
---------------------------------

Note: Mozilla's default size if no size is specified is 6px (that last testcase)
Note: NS4 has the same problem as Mozilla on this page

Over to HTMLFrames to investigate the IE behavior and figure out what's up here.
 (that is, whether this is an evangelism bug).

Todd, what version of IE are you using exactly?  (please comment in this bug)
Assignee: asa → evaughan
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLFrames
Ever confirmed: true
QA Contact: doronr → amar
Summary: Viewing of msdn library not so nice → MSDN has 1px hard-to-drag frameborder (different rendering from IE)
(Reporter)

Comment 3

17 years ago
I am using IE 5.50.4134.0600IS
I think it's just the one that came with win2k service pack 1

Updated

17 years ago
Target Milestone: --- → mozilla1.2
Bulk re-assigning all of Eric's HTMLFrame bugs to John.
Assignee: eric → jkeiser
*** Bug 124266 has been marked as a duplicate of this bug. ***
*** Bug 139757 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
The MSDN site specifies frameSpacing=6 for the inner frameset (whose name is
fstMain).
This nonstandard attribute is what makes IE provide a wide draggable border.
I tested this in IE by saving as "Web page, complete", editing the framespacing
to a large value and reloading.
I see.
Assignee: jkeiser → susiew
Component: Layout: HTML Frames → US General
Product: Browser → Tech Evangelism
QA Contact: amar → zach
Target Milestone: mozilla1.2alpha → ---
Version: Trunk → unspecified

Comment 9

16 years ago
Is this not the same as epic log of ms.com support site issues? They have a bug
on file to fix their detection and I would hope they fix that at the same time.
-->bclary to decide if this should be marked a dupe.

http://bugzilla.mozilla.org/show_bug.cgi?id=159494 
Assignee: susiew → bclary

Updated

16 years ago
Keywords: evang500

Updated

16 years ago
Blocks: 114158
Priority: -- → P2

Comment 10

16 years ago
tech evang june 2003 reorg
Assignee: bc → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: MSDN has 1px hard-to-drag frameborder (different rendering from IE) → microsoft.com - MSDN has 1px hard-to-drag frameborder (different rendering from IE)

Updated

14 years ago
Keywords: top500

Updated

14 years ago
Keywords: top100
*** Bug 281277 has been marked as a duplicate of this bug. ***

Comment 12

8 years ago
Based on URL in bug summary (zbarsky.org seem unreachable) MSDN frame bar behaves identically with Firefox 3.6.x and IE8.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

Comment 13

8 years ago
Marked FIXED as per comment 12.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.