Searchbar uses grayscale antialiasing when scrolling

REOPENED
Unassigned

Status

()

Core
Graphics: Text
REOPENED
3 years ago
a year ago

People

(Reporter: Elbart, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8519486 [details]
grayscale aa in search.png

When entering text into the searchbar, it's antialiased with cleartype (rainbow-colors).

Enter more text than the searchbar can display, so it has to scroll to the side. This is when the antialiasing switches to grayscale (top of the screenshot).

After entering text, about two seconds later the text noticeably (probably depending on your monitor's dpi and cleartype-setting) switches back to cleartype (bottom of the screenshot).

For comparison, text in the urlbar doesn't switch to grayscale when scrolling to the side.
(Reporter)

Updated

3 years ago
Blocks: 622482
See Also: → bug 629891
Can you still reproduce the issue in latest stable Firefox version or in latest Nightly?
Flags: needinfo?(elbart)
(Reporter)

Comment 2

a year ago
Yes.
Flags: needinfo?(elbart)
Please attach as attachment here your about:support (use "copy text to clipboard" button) from Nightly.
Flags: needinfo?(elbart)
(Reporter)

Comment 5

a year ago
It's not depending on gfx-card or driver-version.
Flags: needinfo?(elbart)
I wasn't talking about dependency, I was talking about complete information from about:support from Nightly. Could you post it?
Flags: needinfo?(elbart)
I'm asking because it could be fixed in Nightly which contains fixes for bug #1007702 and bug #1303570,
about:support is needed for checking what preferences are modified and backended is used where.
It should be fixed starting from Mozilla Firefox 52 per:
- Skia being enabled by default(Windows - bug #1007702, Linux - bug #1278957, Mac - bug #1207332)
- bug #1303570 (leftovers will be tracked in bug #1307833).

Duping this bug to bug #1307833 to later easier tracking, instead of incomplete or worksforme, because of no reporter reply.
No longer blocks: 622482
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(elbart)
Resolution: --- → DUPLICATE
See Also: bug 629891
Duplicate of bug: 1307833
Using Skia doesn't magically make us use sub-pixel where we were using grayscale AA. Please test this before concluding that it's fixed.
Blocks: 622482
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Blocks: 1307833
Maybe you missed, but I also wrote about bug #1303570.
You need to log in before you can comment on or make changes to this bug.