Closed Bug 1095958 Opened 8 years ago Closed 7 years ago

[e10s] removing form autocomplete entries with delete doesn't work

Categories

(Toolkit :: Form Manager, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
e10s m8+ ---

People

(Reporter: suirtemedb, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141108030205

Steps to reproduce:

I navigated to a page with a search box such as reddit.com (the search is in the top right) I double clicked and saw that there were multiple suggestions that I didn't wish to be there anymore. I hovered over them and hit the 'backspace' key.


Actual results:

Nothing happened.


Expected results:

The suggestion should have been deleted but it wasn't.
tracking-e10s: --- → ?
Component: Untriaged → Form Manager
Product: Firefox → Toolkit
Summary: [e10s] removing quick suggestions with delete doesn't work → [e10s] removing form autocomplete entries with delete doesn't work
Version: 36 Branch → Trunk
Flags: firefox-backlog+
Confirmed in 38.0a1 (2015-01-20) Win 7 e10s ON.
Works fine with e10s OFF`
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1123800
Duplicate of this bug: 1126829
Error when press Del key:

Timestamp: 2015/04/19 10:06:17
Error: TypeError: this.formHistory is null
Source File: jar:file:///D:/fuku/MyDownload/firefox-nightly.en-US.win32/omni.ja!/components/nsFormAutoComplete.js
Line: 509

Timestamp: 2015/04/19 10:06:17
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "this.formHistory is null" {file: "jar:file:///D:/fuku/MyDownload/firefox-nightly.en-US.win32/omni.ja!/components/nsFormAutoComplete.js" line: 509}]'[JavaScript Error: "this.formHistory is null" {file: "jar:file:///D:/fuku/MyDownload/firefox-nightly.en-US.win32/omni.ja!/components/nsFormAutoComplete.js" line: 509}]' when calling method: [nsIAutoCompleteResult::removeValueAt]
Source File: resource://gre/modules/nsFormAutoCompleteResult.jsm
Line: 180
Duplicate of this bug: 1154684
Duplicate of this bug: 1165941
This ended up being fixed by bug 1162329.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
See Also: → 1258921
You need to log in before you can comment on or make changes to this bug.