Message Body is uneditable on latest Daily Error in MsgComposeCommands shown in Console

RESOLVED DUPLICATE of bug 1099866

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1099866
4 years ago
4 years ago

People

(Reporter: martin, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141108030205

Steps to reproduce:

Click Write to open new Message Editor
Editor Window opens



Actual results:

Message Body is not editable


Expected results:

Message Body should be editable


Error displayed in Console:
Timestamp: 09.11.2014 01:34:27
Error: TypeError: data.slice is not a function
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 1990
BuildID 20140610001341
(Reporter)

Updated

4 years ago
Component: Untriaged → Mail Window Front End
Hardware: x86 → x86_64
(Reporter)

Comment 1

4 years ago
Can also reproduce this in save mode, with all extensions disabled.
(Reporter)

Updated

4 years ago
Summary: MsgComposeCommands → Message Body is uneditable on latest Dayly Error in MsgComposeCommands shown in Console

Comment 2

4 years ago
presumably you are reporting this against 2014-11-08 Thunderbird build or something very current. 
What's the last build date where you don't get the error?
Component: Mail Window Front End → Message Compose Window
Flags: needinfo?(martin)
Summary: Message Body is uneditable on latest Dayly Error in MsgComposeCommands shown in Console → Message Body is uneditable on latest Daily Error in MsgComposeCommands shown in Console
(Reporter)

Comment 3

4 years ago
From Config Editor pref toolkit.telemetry.previousBuildID 20140610001341
(hope that is the right place to look)
On the next dayly update I got the error, reinstalled the build I downloaded after that, which is still fine (since I did turn off automatic updates)
Did not yet try to update again.
The Dayly Installer that works for me has a MD5 hash of C6A0D47658A91CAF37639A85B4EEADDE
and SHA1 1CFACFFED33955852B40A14FC65A5400FCE04A58
Downloaded from https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/thunderbird-36.0a1.en-US.win64-x86_64.installer.exe
Flags: needinfo?(martin) → needinfo?(vseerror)
(Reporter)

Comment 4

4 years ago
About: Buildconfig hast the following for the last working dayly:
about:buildconfig
Build Machine

B-2008-IX-0142
Source

Built from https://hg.mozilla.org/mozilla-central/rev/17e190839086
Build platform
target
x86_64-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
cl 	1600 	-TC -nologo -D_HAS_EXCEPTIONS=0 -W3 -Gy -wd4244 -wd4267 -wd4819 -we4553
cl 	1600 	-TP -nologo -D_HAS_EXCEPTIONS=0 -W3 -Gy -wd4251 -wd4244 -wd4267 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR- -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oi -Oy-
Configure arguments

--enable-crashreporter --enable-release --target=x86_64-pc-mingw32 --host=x86_64-pc-mingw32 --enable-application=mail --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-signmar --enable-profiling --enable-calendar --with-external-source-dir=c:/builds/moz2_slave/tb-c-cen-w64-ntly-000000000000/build

Comment 5

4 years ago
(In reply to martin from comment #3)
> From Config Editor pref toolkit.telemetry.previousBuildID 20140610001341
> (hope that is the right place to look)

The place to look is Help | Troubleshooting | application buildid
Flags: needinfo?(vseerror) → needinfo?(martin)
(Reporter)

Comment 6

4 years ago
Ah yes right: says Application Build ID 	20141107030200
Flags: needinfo?(martin) → needinfo?(vseerror)
(Reporter)

Comment 7

4 years ago
Just tried updating again (to Application Build ID 	20141119030206 ), error persists , so I'll go back to the last build that works for me (says Application Build ID 	20141107030200)

Comment 8

4 years ago
From the error console report:
Timestamp: 09.11.2014 01:34:27
Error: TypeError: data.slice is not a function
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
This is the same as bug 1099866
which has a patch awaiting review.
The easy workaround is to go to Tools..Options..Composition..General and set "Check for missing attachment"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1099866
(Reporter)

Comment 9

4 years ago
Ah wonderful, Thanks Joe, I can confirm, that this is indeed a dupe of bug 1099866 , just updated, set the pref and it works.
Flags: needinfo?(vseerror)
You need to log in before you can comment on or make changes to this bug.