cannot disable NFC dialog on scanning an NFC tag

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: Ernest Beinrohr, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141015093046

Steps to reproduce:

- install autora apk (35.0a2) from the ftp
- scan an NFC tag
- select another app for the action
- scan the NFC again


Actual results:

the app select dialog for NFC is ALWAYS displayer.


Expected results:

After the first selection the dialog should not pop up again.

PS: I'm not the only one (https://www.reddit.com/r/firefox/comments/1r8c5o/disabling_nfc_in_firefox_mobile/)
(In reply to Ernest Beinrohr from comment #0)
> Steps to reproduce:
> 
> - install autora apk (35.0a2) from the ftp
> - scan an NFC tag

Can you expand on these steps? "Scan an NFC tag". What third party application are you using?

> - select another app for the action

What does this mean?

> - scan the NFC again

Does this mean you are switching away from the browser?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(Ernest)
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> (In reply to Ernest Beinrohr from comment #0)
> > Steps to reproduce:
> > 
> > - install autora apk (35.0a2) from the ftp
> > - scan an NFC tag
> 
> Can you expand on these steps? "Scan an NFC tag". What third party
> application are you using?

If you have NFC enabled on your android, putting your phone to an NFC tag creates an internal action. So no app yet.

> 
> > - select another app for the action
> 
> What does this mean?

After putting your phone near an NFC tag, an select dialog appears (if you have multiple apps, which subscribe to the NFC action). 

> 
> > - scan the NFC again
> 
> Does this mean you are switching away from the browser?

Well, the browser isn't started yet. On this reflection, maybe this bug should be filed agains android/cyanogenmod.
Flags: needinfo?(Ernest)
Can you check wether you can reproduce on a device without CyanogenMod?
(Reporter)

Comment 4

4 years ago
On an HTC android with both aurora and NFC-retag this is not an issue. So it looks like an cyanogenmod issue.
Resolution: INCOMPLETE → INVALID
You need to log in before you can comment on or make changes to this bug.