If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

URL not underlined, clickable, linkified in received HTML message

RESOLVED WONTFIX

Status

Thunderbird
Message Reader UI
RESOLVED WONTFIX
3 years ago
7 months ago

People

(Reporter: Robert Orzanna, Unassigned)

Tracking

32 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8519724 [details]
URL is not clickable, nor linkified

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141029050740

Steps to reproduce:

The following snippet of a HTML text message contains a URL which is not linkified. See the attached screenshot.

Snippet:

"Fixing this requires changes on the Thunderbird side, for which I
submitted a patch at https://bugzilla.mozilla.org/show_bug.cgi?id=1096119"



Expected results:

Any idea why the URL [1] is not underlined and clickable?

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1096119
wfm TB 31.3.0 on WinXP

can you try if linkification works in TB Safe Mode, Help > Restart with all addons disabled

can you attach msg source as testcase, perhaps there's something in source code not visible on surface

I'm also surprised the link in the signature is not linkified
Reporter (Robert), can you please answer comment 1? Otherwise there's nothing we can do for you.
Flags: needinfo?(orschiro)
Whiteboard: [closeme 2015-03-07]
(Reporter)

Comment 3

3 years ago
Created attachment 8567798 [details]
Message source

Thomas: Apologises for the late response. Please view the attached message source. It also does not work in Safe Mode.
Flags: needinfo?(orschiro)

Comment 4

3 years ago
I don't believe we auto-linkify URLs in HTML mail. I don't think we *should*, either; if the sender chooses not to linkify it, we should respect that. We could do like Firefox and allow opening the link via the context menu, though.

This is probably a bug in GitHub's mail composer, since links work just fine in the GitHub mails I get.

Updated

3 years ago
Whiteboard: [closeme 2015-03-07]
Summary: URL not underlined, clickable, linkified → URL not underlined, clickable, linkified in received HTML message
>  We could do like Firefox and allow opening the link via the context menu, though.
I think there is an addon which does this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Component: Untriaged → Message Reader UI
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.