Closed Bug 1096190 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][Browser][WAP]The browser displayed in the portrait mode at first when you enter browser in landscape.

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: sync-1, Assigned: yifan)

References

Details

Attachments

(1 file)

258.17 KB, application/octet-stream
Details
Created an attachment (id=998427)
 mtklog
 
 PR Reporter:邢艳
 contact:0752-2639551(61551)
 		
 
  DEFECT DESCRIPTION:
 >The browser displayed in the portrait mode at first when you enter browser in landscape.
 
  REPRODUCING PROCEDURES:
 1.Make sure the auto-rotate screen function is on;
 2.Enter browser in landscape mode, but the screen displayed in the portrait mode at first,then displayed in landscape mode after a while.--KO
 
 PS:Soul 3.5FF 也有这个问题,安卓上对比了是OK的。
 附件为MTKlog.
 
  EXPECTED BEHAVIOUR:
 >The browser should display in the landscape mode.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached file mtklog
Hi Yi-Fan,
Could you please help to check the problem? Thanks!
Blocks: Woodduck
blocking-b2g: --- → 2.0M?
Flags: needinfo?(yliao)
Assignee: nobody → yliao
Flags: needinfo?(yliao)
Hi Josh, I noticed the same behavior on FF on my Android, the only difference is that there's a rotate animation from portrait to landscape. Not sure if it's by design.

Hi UX team, could you help to clarify if this is a defect or a feature request? Thank you.
Flags: needinfo?(firefoxos-ux-bugzilla)
Triage: 
polish. Not fix in 2.0M.
blocking-b2g: 2.0M? → ---
Flagging Francis on this one.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(fdjabri)
I think the right behaviour is to open the app in portrait and then transition to landscape, but we could probably do better on the animation. Flagging Eric and Przemek as this should be part of a common design language and not specific to browser.
Flags: needinfo?(pabratowski)
Flags: needinfo?(fdjabri)
Flags: needinfo?(epang)
I talked to Eric and we feel the current behavior and look is fine. We can add an animation but I feel it may cause performance issues especially for complex websites our lower end phones.
Flags: needinfo?(pabratowski)
Flags: needinfo?(epang)
Blocks: Woodduck_P2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.