Closed Bug 1096217 Opened 7 years ago Closed 7 years ago

[Flame][Settings]The DCIM folder can't be found in PC after you take photo.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1074593
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: liuke, Unassigned, NeedInfo)

Details

Attachments

(4 files)

Attached file logcat_1605.txt
[1.Description]:
[Flame][v2.1][Settings]Delete the DCIM folder in PC, then take photo, the DCIM folder can't be found in PC.
Found yime:16:05
See attachment:1605.mp4 and logcat_1605.txt

[2.Testing Steps]: 
1. USB plugged in on PC 
2. Device enable MTP 
>> PC could access the storages 
3. Set current default media location as internal storage 
4. Delete image folder(ex DCIM) on internal storage from PC 
5. Device take a picture 
>> Image folder would be created on PC and PC could see the new picture under image folder 

[3.Expected Result]: 
5.The DCIM folder should be found in PC after you take photo.

[4.Actual Result]: 
5.The DCIM folder can't be found in PC.

[5.Reproduction build]: 
Gaia-Rev        0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/97487a2d1ee6
Build-ID        20141109001201
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Attached video 1605.MP4
This bug has been verified to fail on Flame 2.1, 2.2.
Issue steps:
1. USB plugged in on PC 
2. Device enable MTP 
>> PC could access the storages 

3. Set current default media location as internal storage 
4. Delete image folder(ex DCIM) on internal storage from PC 
5. Device take a picture 
>> Image folder would be created on PC and PC could see the new picture under image folder 

[3.Expected Result]: 
5.The DCIM folder should be found in PC after you take photo.

[4.Actual Result]: 
5.The DCIM folder can't be found in PC.

Found time:17:19
See attachment: logcat_1719.txt
Reproducing rate: 5/5

Flame 2.1 version:
Gaia-Rev        14315733e2d265a42f9ab02d1aba191789870f70
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-2g34_v2_1/rev/ddecea83ce6e
Build-ID        20141217001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141217.093749
FW-Date         Wed Dec 17 09:38:04 EST 2014
Bootloader      L1TC00011880

Flame 2.2 version:
Gaia-Rev        d22dfece04fc00457e8369c660c11f945b088d2f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/cb8ad2251c09
Build-ID        20141217160203
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141217.193852
FW-Date         Wed Dec 17 19:39:02 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(hlu)
Attached file logcat_1719.txt
The problem is verified not happen on latest Flame 2.2 build, but it still exist in Flame 2.1.

Issue steps:
1. USB plugged in on PC 
2. Device enable MTP 
>> PC could access the storages 

3. Set current default media location as internal storage 
4. Delete image folder(ex DCIM) on internal storage from PC 
5. Device take a picture 
>> Image folder would be created on PC and PC could see the new picture under image folder 

[3.Expected Result]: 
5.The DCIM folder should be found in PC after you take photo.

[4.Actual Result]: 
Flame 2.1: 5.The DCIM folder can't be found in PC.
Flame 2.2: 5.The DCIM folder have been found in PC after you take photos.

Flame 2.1: Fail rate: 5/5
Flame 2.2: Fail rate: 0/5

See attachment:logcat_1617.txt
Found time:16:17

Flame 2.1 version:
Gaia-Rev        64db236bea9a0510567ab7ced2f2b4688737123c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/273f24a1d1fe
Build-ID        20150111001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150111.035122
FW-Date         Sun Jan 11 03:51:33 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 version:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150111.043244
FW-Date         Sun Jan 11 04:32:55 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(mlien)
Attached file logcat_1617.txt
Hi Alison, could you help with this, thanks.
Flags: needinfo?(mlien) → needinfo?(ashiue)
This is a dup bug of bug 1074593, according to bug 1074593 comment 5, this issue is not a 2.1 blocking bug, so the fixing is only on 2.2 and after version. 

It's my bad that I should remove test case 14867 from 2.1 version.
I've already updated it.
https://moztrap.mozilla.org/manage/cases/?filter-id=14867 

Thanks for your finding.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ashiue)
Resolution: --- → DUPLICATE
Duplicate of bug: 1074593
You need to log in before you can comment on or make changes to this bug.