"AttributeError: 'NoneType' object has no attribute 'app'" when bisecting on inbound

RESOLVED DUPLICATE of bug 1105856

Status

Testing
mozregression
--
major
RESOLVED DUPLICATE of bug 1105856
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or 'exit' and press Enter): g
Got as far as we can go bisecting nightlies...
Ensuring we have enough metadata to get a pushlog...
Last good revision: 0b81c10a9074 (2014-11-03)
First bad revision: 5dde8ea48fef (2014-11-04)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b81c10a9074&tochange=5dde8ea48fef

... attempting to bisect inbound builds (starting from previous week, to make sure no inbound revision is missed)
Getting http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/10/2014-10-27-11-30-17-mozilla-central/firefox-36.0a1.en-US.win64-x86_64.txt
Getting inbound builds between da125623d9cb and 5dde8ea48fef
Traceback (most recent call last):
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\Scripts\mozregression-script.py", line 9, in <module>
    load_entry_point('mozregression==0.25', 'console_scripts', 'mozregression')()
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 365, in cli
    app()
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 363, in <lambda>
    get_date(options.bad_date))
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 208, in bisect_nightlies
    self.bisect_nightlies(good_date, mid_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 205, in bisect_nightlies
    self.bisect_nightlies(mid_date, bad_date)
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 176, in bisect_nightlies
    self.bisect_inbound()
  File "c:\Users\Ed\.virtualenvs\tmp-eb7c0c5a956f6292\lib\site-packages\mozregression\regression.py", line 107, in bisect_inbound
    inbound_revisions = self.inbound_runner.app.build_finder \
AttributeError: 'NoneType' object has no attribute 'app'
(Reporter)

Comment 1

4 years ago
Was able to resume using:

$ mozregression --good 2014-11-03 --bad=2014-11-04 --app=firefox --bits=32
This is a duplicate of bug 1105856. mozregression 0.28 fixes this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1105856
You need to log in before you can comment on or make changes to this bug.