No warning on closing Private Window with multiple tabs

RESOLVED DUPLICATE of bug 987821

Status

()

RESOLVED DUPLICATE of bug 987821
4 years ago
4 years ago

People

(Reporter: beneficentone, Unassigned)

Tracking

33 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141027150301

Steps to reproduce:

Check 'Warn me when closing multiple tabs'.  Open a Private Window.  Open multiple tabs.  Close window (with X or Alt+F4).


Actual results:

Window closes immediately.


Expected results:

'You are about to close [#] tabs. Are you sure you want to continue?' warning should be displayed.

Notes:

- This is a data loss issue, because the contents of the Private Window cannot be restored and the window could easily be closed by accident.

- This is not a new issue; it dates back to at least 27.0.1.
(Reporter)

Comment 1

4 years ago
There is one scenario I've found where the dialog *does* display: There's only one window open and it's Private.  Additionally, browser.showQuitWarning is set to false (default setting).
This is intentional. See bug 987821 comment 2: we want closing private windows to be as quick as possible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987821
You need to log in before you can comment on or make changes to this bug.