Update Firefox Developer Edition Download button

VERIFIED FIXED

Status

www.mozilla.org
Pages & Content
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: cmore, Assigned: jgmize)

Tracking

(Blocks: 1 bug)

Production

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Updated

4 years ago
Assignee: nobody → jmize
(Reporter)

Comment 3

4 years ago
We'll need these verified:

* /firefox/developer/

** works for en-US

*** works for win32
*** works for osx
*** works for linux

** works for non-en-US

*** works for win32
*** works for osx
*** works for linux

* /firefox/channel/

** works for en-US

*** works for win32
*** works for osx
*** works for linux

** works for non-en-US

*** works for win32
*** works for osx
*** works for linux

works = 200 OK on download file.
(Reporter)

Comment 4

4 years ago
Some changes, in comment 0, it is win and not win32 for the os value.

There is also a stub for win and en-US only:

http://download.mozilla.org/?product=firefox-aurora-stub&os=win&lang=en-US

Non-en-US win locales should get:

http://download.mozilla.org/?product=firefox-aurora-latest-l10n&os=win&lang=fr
(Related, I've added a GitHub Issue to have us figure out which additional Bouncer test-automation coverage we need to add: https://github.com/mozilla/bouncer-tests/issues/65)

Comment 6

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/50d8e7bf50306607623ac0077ff60ea10e1b11b4
Change dev browser dl link: fix bug 1096393

https://github.com/mozilla/bedrock/commit/4f314e7dbe3924e2c51a9908431491925e1d1a4f
Merge pull request #2475 from jgmize/dev-browser-bouncer

Change dev browser dl link: fix bug 1096393

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I've added a new product in bouncer so that the full installer downloads can be fetched over ssl.

The new product is "firefox-aurora-latest-ssl". non-en-US should still use "firefox-aurora-l10n", which was and is still ssl.
(Reporter)

Comment 9

4 years ago
jgmize: ^^

We now have SSL products for OSX/Linux on en-US. Everything else is already over SSL.
Status: RESOLVED → REOPENED
Flags: needinfo?(jmize)
Resolution: FIXED → ---

Comment 11

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/466034255cb30f9b17beba6bf3c3815a11e37147
Use new aurora ssl product for dl: fix bug 1096393

https://github.com/mozilla/bedrock/commit/d9ed3b1b6958c5ece56159b8963a7fc6d1c82915
Merge pull request #2481 from mozilla/aurora-latest-ssl

Use new aurora ssl product for dl: fix bug 1096393

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

4 years ago
Verified using SSL product (with working redirect) on
https://www.mozilla.org/en-US/firefox/channel/#aurora and https://www.mozilla.org/en-US/firefox/developer/
Status: RESOLVED → VERIFIED

Updated

4 years ago
Blocks: 813052

Updated

4 years ago
Duplicate of this bug: 797914
You need to log in before you can comment on or make changes to this bug.