Closed Bug 1096512 Opened 8 years ago Closed 8 years ago

[Browser] On "Improve Firefox OS - Learn More" screen, there is overlapping of the text box and texts

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 fixed, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- fixed
b2g-v2.2 --- verified

People

(Reporter: fmuyumba, Assigned: etienne)

References

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-3])

Attachments

(3 files)

Attached image 2014-11-10-11-31-01.png
Description:
While in "Improve Firefox OS" when the User taps on "Learn More", the screen that opens up has an overlapping "Search" text box and texts
   
Repro Steps:
1) Update a Flame device to BuildID: 20141110001201
2) Launch "Settings"
3) Tap on "Improve Firefox OS"
4) Tap on "Learn More"
5) Observe what happens to "Search" text box and some texts
  
Actual:
There is an overlapping of texts and text box

Expected: 
No overlapping of texts and text boxes
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110001201
Gaia: 0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko: 97487a2d1ee6
Version: 34.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 100%
See attached: screenshot & logcat
Flags: needinfo?(jmitchell)
This issue is NOT reproducible on Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash) and Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)

Result: 
While in "Improve Firefox OS" when the User taps on "Learn More", the screen that opens up does NOT have an overlapping text box and texts

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110040206
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: d380166816dd
Version: 36.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-------------------------------------------------------------------------------------------------------------------

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110000204
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 7198906837e7
Version: 32.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
NI to browser owner for a blocking call - Regression and improperly formatted page so probably yes
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mozillamarcia.knous)
I see this issue on 2.1 Flame when I open that link from Settings, but it doesn't occur when I open the same page in Browser. The other thing I noticed is that the rocketbar doesn't expand and collapse on the page when I open it from Settings.
Flags: needinfo?(mozillamarcia.knous)
[Blocking Requested - why for this release]: Nominating so we can investigate why this is happening in 2.1 and not 2.2 - something is clearly wrong with the way the page is being opened from Settings on 2.1.
blocking-b2g: --- → 2.1?
blocking-b2g: 2.1? → 2.1+
Probably the same cause as 1095702.
Flags: needinfo?(kgrandon)
Flags: needinfo?(bfrancis)
I've confirmed that this could actually be fixed by uplifting bug 1066607. Marking the dependency and marking this as fixed as it's fixed on master.
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 1066607
Flags: needinfo?(kgrandon)
Flags: needinfo?(bfrancis)
Resolution: --- → FIXED
Assignee: nobody → etienne
Target Milestone: --- → 2.1 S5 (26sep)
Verified the issue is fixed on Master 2.2 as per comment 7 by uplifting fix for bug 1066607

On the "Learn More" page the icon doesn't overlap the text

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141114040205
Gaia: 1e300eac2e56d98ad51d414766d031db7d33221f
Gecko: bbb68df450c2
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
====================================================================
Leaving "verifyme" for 2.1 Patch
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
Please check 2.1 on Monday's build since the patch has been uplifted to 2.1 on bug 1066607
Flags: needinfo?(ktucker) → needinfo?(sarsenyev)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
After checked the issue on 2.1 as per comment 9, the issue still reproduces

The "Mozilla wiki" icon overlapping the text

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"
==================================================================
Leaving verifyme for 2.1
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(sarsenyev) → needinfo?(ktucker)
Comment 7 from bug 1096512 stated that  uplifted fix for bug 1096512 will fix the issue, but the issue still reproduces on 2.1 even when it's fixed the bug 1096512
As mentioned in comment 2 the bug doesn't repro in 2.2 and 2.0 only 
Opened a new bug 1100619 for the issue bug
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.