Closed Bug 1096523 Opened 5 years ago Closed 5 years ago

Firefox Developer Edition bitmap looks awful with hiDPI (logo image)

Categories

(Firefox :: Installer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
firefox40 --- fixed

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

Attachments

(5 files, 2 obsolete files)

Attached image screenshot
See screenshot.

I think the options and downloading page background color should also be changed to a color closer to the first page graphic background.
I think using the following bmp as a guide would help
http://mxr.mozilla.org/mozilla-central/source/browser/branding/nightly/appname.bmp

shorlander, I'll test it out if you can provide a new bmp.
Flags: needinfo?(shorlander)
Summary: Firefox Dev Edition bitmap looks awful with hiDPI → Firefox Dev Edition bitmap looks awful with hiDPI (logo image)
Duplicate of this bug: 1121536
Summary: Firefox Dev Edition bitmap looks awful with hiDPI (logo image) → Firefox Developer Edition bitmap looks awful with hiDPI (logo image)
Duplicate of this bug: 1155183
Stephen, can I get a new bitmap for this or help out in some way to get this fixed?
Flags: needinfo?(shorlander)
Stephen, can you create a bitmap for Firefox Developer Edition with the qualities of the nightly bitmap as you did way back when? Thanks
Attachment #8599002 - Attachment is obsolete: true
Attachment #8599003 - Attachment is obsolete: true
Attachment #8599008 - Flags: feedback?(shorlander)
Yes. I will have to play around with it a bit. Not sure why it works some times but not others.
Flags: needinfo?(shorlander)
It is due to HiDPI... same problem you fixed by creating the larger images similar to the nightly image when the stub installer was first implemented
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #9)
> It is due to HiDPI... same problem you fixed by creating the larger images
> similar to the nightly image when the stub installer was first implemented

Resolution wise the Developer Edition image is the same @4x size we used before for Aurora and Nightly. The dimensions are different: 369 x 174 for the Dev Edition image vs. the previous 944 x 144 for the Aurora image.

So I don't fully understand why this image is not scaling cleanly. Although it might have to do with the dimensions of the image not matching what is in branding.nsi (http://mxr.mozilla.org/mozilla-central/source/browser/branding/aurora/branding.nsi#29) It should be 372 x 176

I will change it to match those. Not sure how I ended up with those weird dimensions anyway :)
Attached image intro page
I increased the height of the bitmap by 1 pixel so it rounded properly and used the following for dialog units

!define APPNAME_BMP_WIDTH_DU 123u
!define APPNAME_BMP_HEIGHT_DU 56u

Stephen, what do you think?
Attachment #8599352 - Flags: feedback?(shorlander)
Comment on attachment 8600527 [details] [diff] [review]
patch

Stephen, I'd like to get this landed before the merge. Thanks!
Attachment #8600527 - Flags: review?(shorlander) → review?(spohl.mozilla.bugs)
Comment on attachment 8600527 [details] [diff] [review]
patch

Review of attachment 8600527 [details] [diff] [review]:
-----------------------------------------------------------------

The dialog in comment 11 certainly looks much better than before. Please make sure that my r+ is sufficient before landing. Thanks!
Attachment #8600527 - Flags: review?(spohl.mozilla.bugs) → review+
I discussed this with Gavin before requesting review and if there are changes needed it can be done in a followup after this lands.
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/84a6852a3733
Assignee: nobody → robert.strong.bugs
Flags: in-testsuite-
Target Milestone: --- → Firefox 40
https://hg.mozilla.org/mozilla-central/rev/84a6852a3733
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8599352 [details]
intro page

It does look better. But some of the magenta color that is supposed to be transparent is bleeding through.
Attachment #8599352 - Flags: feedback?(shorlander)
The magenta color is likely not the correct magenta color and that is as good as I could get it with my image editing tools. The one thing I notice about the nightly appname.bmp and the aurora appname.bmp is that the edges are smooth in the nightly one and jagged in the aurora one. I suspect that if the aurora one was smoothed out like the nightly one along with the change to the image dimensions that it would fix that.
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #21)
> The magenta color is likely not the correct magenta color and that is as
> good as I could get it with my image editing tools. The one thing I notice
> about the nightly appname.bmp and the aurora appname.bmp is that the edges
> are smooth in the nightly one and jagged in the aurora one. I suspect that
> if the aurora one was smoothed out like the nightly one along with the
> change to the image dimensions that it would fix that.

The Nightly BMP is also sharp AFAIK — http://cl.ly/image/3Y2k0T2o2K0c. 

My understanding of how the transparency is that it samples the top left pixel and is supposed to make that color transparent.

I will try a few things once my build is complete.
You need to log in before you can comment on or make changes to this bug.