[Loop] Stretching screen from bottom while in loop options causes a rift that lets you see the page beneath it

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rmead, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3][mobile app][not blocking][tef-triage], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8520156 [details]
Flame2.1logcat.txt

Description:
While in the loop app, if you go to the options screen, scroll down to the bottom, and stretch it upwards, a tear in the layer becomes apparent.
   
Prereq:
Have the loop app installed

Repro Steps:
1) Update a Flame device to BuildID: 20141107001205
2) Tap the 'Firefox Hello' app
3) Tap the 'Settings' icon in the upper right corner
4) keep swiping upwards until you are at the bottom of the page trying to stretch it. Observe.

Actual:
The area right above the Version row tears and you can see the layer behind it.

Expected: 
The area should stretch without a break opening up in the layer


Flame 2.1(319mb)(KitKat)(Shallow Flash)

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110001201
Gaia: 0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko: 97487a2d1ee6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  

Repro frequency: 100%
See attached: logcat, video - http://youtu.be/OvPty_SrM9s
(Reporter)

Comment 1

4 years ago
This issue also occurs on Flame 2.2(319mb) but instead of a tear, there are a bunch of extra lines that get drawn when you try to stretch.

In the loop app settings, if you scroll to the bottom and try to stretch the screen upwards, the area right above the Version row has line artifacts that appear when you try to stretch the screen.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110040206
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: d380166816dd
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


The issue does not occur in Flame 2.0(319mb) because the stretch UX for scrolling was not yet implemented.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110000204
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 7198906837e7
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
NI Loop owner for blocking decision
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mbarone976)
This issue also occurs on 2.0 version, anyway although it's not a blocking bug, it's a ugly, let's try to fix for 1.1.1 version.

Cristian, can you have a look at it when you have bandwidth and we finish the v1.1.1 feature implementation? Thanks a lot!
Flags: needinfo?(crdlc)
Severity: normal → minor
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][mobile app][not blocking][tef-triage]

Updated

4 years ago
Flags: needinfo?(mbarone976)
(Assignee)

Comment 4

4 years ago
Created attachment 8521201 [details]
Github pull request

Thanks
Flags: needinfo?(crdlc)
Attachment #8521201 - Flags: review?(carmen.jimenezcabezas)
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Comment on attachment 8521201 [details]
Github pull request

Thanks!
Attachment #8521201 - Flags: review?(carmen.jimenezcabezas) → review+
Duplicate of this bug: 1097335
(Assignee)

Comment 7

4 years ago
Merged in master:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/59567f8ab2eb9afc9a1e2fb448850151e02df9c2
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.