Custom User-Agent for Firefox Developer Edition

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: groovecoder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Sorry if this is already discussed/decided.

Firefox DE does not send anything in the User Agent string to distinguish it from Firefox? Is that by design?

It will help creators of developer-oriented sites (like MDN :) to know how many users are visiting from Firefox vs. Firefox Developer Edition.

Comment 1

3 years ago
Is that by design?

Yes, I hope so.
No more userAgent rambling, please!

Bug 799899, Bug 728831, Bug 591573, Bug 591537, Bug 581008, 
Bug 572668, Bug 581783, Bug 572659, Bug 572656, etc.
It was never suggested that we use a different user-agent and as far as I know, the recommendation to sites from Mozilla is to not use user-agent sniffing. Developer Edition keeps using what Aurora used before.

You can easily count the Developer Edition users however, by correlating the Firefox version number with the date of the visit.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
I suppose that's what we'll have to do. But that makes it exactly 8.6x harder to track Firefox Developer Edition adoption rates over a year. :/
Fair enough, but we do have new telemetry data that should provide better estimates on Developer Edition adoption. Talk to Jeff Griffiths if you are interested in the data or the dashboards he is building.
You need to log in before you can comment on or make changes to this bug.