This site fails under Mozilla

CLOSED WORKSFORME

Status

()

--
major
CLOSED WORKSFORME
17 years ago
17 years ago

People

(Reporter: msilva, Assigned: attinasi)

Tracking

Trunk
mozilla1.1alpha
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

In the refered site, the first page isn't shown correctly, the "boxes" with
descriptions are under a "white panel". The site is shown correctly with
Netscape 6.0.

Reproducible: Always
Steps to Reproduce:
1. open http://www.dhtmlcentral.com/


Expected Results:  Open the site as Netscape 6.0.
I see no differences between current nightly rendering and NS 4.7x...

Comment 2

17 years ago
I'm getting *lots* of JS errors on that site ...

Comment 3

17 years ago
2001111108/WinNT4
I'm crashing on this site - is it bug 108940? (TB37892077G, TB37892180K)

http://www.dhtmlcentral.com/ looks better in NN6.1 (20010726) than in M2001111108

Comment 4

17 years ago
Dupe of bug 91900? 

Comment 5

17 years ago
Crashing on this site with Mozilla 0.9.5+
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011113. 

Suggest remarking bug as "this site crashes Mozilla."

Updated

17 years ago
Severity: minor → critical
Keywords: crash
Summary: this site isn't shown correctly with mozilla 0.9.5 → This site crashes Mozilla
(Reporter)

Comment 6

17 years ago
IMHO, I don't agree with the expression "crash" because, after open this site, 
Mozilla continues to work correctly.
Severity: critical → major
Summary: This site crashes Mozilla → This site fails under Mozilla

Comment 7

17 years ago
Manuel, what version of Mozilla are you using?

Mozilla still crashes on this site with Win 98 build id 2001112104. The crashes
for this site are handled by bug 109754.

As for the rendering issues, they are hard to diagnose when Mozilla crashes on
going to the site. I tried Netscape 6.2. It doesn't crash, but it doesn't render
the bottom frame. The rendering issues for dhtmlcentral.com seem to be handled
by bug 91900.

Propose marking this bug as a dupe of bug 91900.

Comment 8

17 years ago
> IMHO, I don't agree with the expression "crash" because, after open this site,
> Mozilla continues to work correctly.

In my experience (Moz 0.9.6, Win 98 FR), the site doesn't crash on first load,
it simply only renders the top of the page. Although, if I try to reload the
page, then Mozilla crashes (I just sent the corresponding talkback data).

Comment 9

17 years ago
Mozilla didn't crash after reloading - 2001112803/WinNT4 

vdeconinck@cplus.be: Can you provide talkback ID and also retry visit DHTML
central with latest version of Mozilla?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
The crash is fixed (bug 109754)

Comment 11

17 years ago
I can confirm that dhtmlcentral.com no longer crashes Mozilla. As of Build
2001120303, part of the web page seems to work. Not all of the boxes are
displayed though.

Maybe we should mark this bug as depending on 91900?

Updated

17 years ago
Keywords: crash
-Layout. confirmed with 120403 windos mozilla build
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 13

17 years ago
I'm having trouble narrowing this one down, but I know there is something 
fundamentally wrong with the javascript. If you render this page in IE6, resize 
the window and watch what happens, the page gets quite distorted. In NS6, the 
page ends up rendering in what looks like two frames. The entire page content is 
in the upper frame, but you can't access (scroll). I am attaching the js, just 
in case it gets changed.

Comment 14

17 years ago
when I try to extract what the passed values are for what is being used to sniff 
out the browser information, all I get is 'undefined' -- I was trying that 
through javascript:alert()

Comment 15

17 years ago
Created attachment 61184 [details]
javascript from the web site

The attached file is the javascript used on the site, there are a few errors
just in the sniffing section of the script. However, NS4 and IE6 render the
pages and NS6 from 2001121003 does not render the site (see my previous notes).
dhtmlcentral.com is officially still in beta, it's not fully tested and the 
scripting on the frontpage hasn't been updated for a while. I'm not sure if it 
should be in bugzilla, it seems like not such a good testcase :/
Target Milestone: --- → mozilla1.1

Comment 17

17 years ago
Please note : dhtmlcentral.com is not only a site, it's mainly a resource center
for webmasters, so it can't be considered a one-site exception.
According to its Forums, dhtmlcentral.com has more than 4000 people registered,
and I'd bet most of them are webmasters, so this bug potentially prevents 4000
sites from showing up OK with Mozilla, and although dhtmlcentral may use the
latest (and still beta) versions of the scripts, many websites out there are
actually using older pretty stable versions
My site ( http://www.indo-chine.org/disco ), for example, is using CoolMenus
(which is tho most complete free DHTML menu system I found) version 3 for more
than six months now and I'm really satisfied with it. It used to be cross
browser (NS4, IE4-5-6, NS6.x & Mozilla up to 0.9.7), but unfortunately it breaks
with the few last nightlies (blank frame instead of menu).
So either this guy has made a mistake or is not standards compliant in some way,
and we should evangelize, or it's actually a Mozilla bug and I volunteer to try
with a few nightlies back and find when it regressed (will do it anyway if I
have time).
Please also note that bug 91900 is about another specific problem of the same site.

Comment 18

17 years ago
the site itself has been revamped and made to work with moz in feb or so.

Comment 19

17 years ago
honk honk, WFM !

Comment 20

17 years ago
Manuel Silva (or somebody else with W98), could you install the latest nightly
build and try it again?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

Comment 21

17 years ago
WFM (buildID: 2002072204)

Could we close this one now ?
/jc

Comment 22

17 years ago
Marking WFM regarding several last comments. 
Reporter: Please try a more recent build and reopen this bug 
if it still occurs for you:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 23

17 years ago
It makes sense to close because the problem is solved with newer versions of
Mozilla.
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.