If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Version 33.1 "What's new" page not loading the video

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Zilmar, Unassigned)

Tracking

Production
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1575257])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

1 - Start Firefox 33.0.3
2 - Update Firefox to 33.1
3 - Restart browser to complete update
4 - Browser restarts and loads page https://www.mozilla.org/pt-BR/firefox/33.1/whatsnew/?oldversion=33.0.3 which doesn't load the video
5 - If "?oldversion=33.0.3" is removed the video works


Actual results:

The video didn't load


Expected results:

The video should load
WFM - tested with your link and also with lang en-US and de-DE
on Win7 64bit

can someone reproduce it?
I could reproduce it after i updated my en-us Release build on windows 7
Removing the query string at the end makes it work.
Status: UNCONFIRMED → NEW
Component: Untriaged → Pages & Content
Ever confirmed: true
Product: Firefox → www.mozilla.org
Version: 33 Branch → Production
Thanks for the report,

Can I ask when you load the page with the query string, are you seeing the gray overlay / doorhanger to start the tour ok?
(Reporter)

Comment 4

3 years ago
I couldn't reproduce at work. The tour showed up and the video works.
At home it didn't load the gray overlay to start the tour. Same OS on both PCs (Windows 7).
(In reply to zilmar.jr from comment #4)
> I couldn't reproduce at work. The tour showed up and the video works.
> At home it didn't load the gray overlay to start the tour. Same OS on both
> PCs (Windows 7).

Thanks! This confirms my suspicion - I think this may actually be the side effect of a profile related issue. 

Looks like your Firefox profile at home does not have the preference enabled to start uitour for some reason.

CC'ing MattN who might be able to help diagnose some more info here.
As for the video not playing, this is because it only gets initialized once someone finishes the tour. 

We should probably have a fallback mechanism that ensures the video is still playable, even if uitour does not get initialized.

Updated

3 years ago
Whiteboard: [kb=1575257]
Hello, do you ever use the Clear Recent History feature? If so, you are probably experiencing bug 506446 and/or bug 1058442. Bug 1050080 should have fixed this issue in Firefox 35, current in the Developer Edition (formerly named Aurora).

Could you test with developer edition using the same profile (uncheck the box in preferences for developer edition to use its own profile) and confirm that the problem is gone?

https://www.mozilla.org/en-US/firefox/channel/#aurora
Flags: needinfo?(zilmar.jr)

Comment 8

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/ecf1c173619f183adecd2de59aed1b9c0e0588d2
[fix bug 1096662] Version 33.1 What's new page not loading the video

https://github.com/mozilla/bedrock/commit/b5b4f2380da668b848d5ba15738620df19a72c9c
Merge pull request #2483 from alexgibson/bug-1096662-whatsnew-video-uitour

[fix bug 1096662] Version 33.1 What's new page not loading the video

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
GitHub robot closed this bug automatically when we merged a fix to make sure the video is still accessible, but I'm re-opening at least until we get confirmation on the cause of uitour API not working.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Closing this one as we're pretty sure of the cause, and the fix we applied to the page at least makes sure the video is still accessible.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(zilmar.jr)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.