Registration page loads in the transition flow even if the account is verified

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
steps to reproduce:
1. Register for a new account on marketplace dev/stage on Firefox 18
2. Confirm the account from the email account on a different Firefox/ browser. I used Firefox 33.0
3. Return to Firefox 18 and click Sign in
4. Enter the recently-verified email.


expected behavior:
Sign in page loads in the transition flow since the account is verified

actual behavior:
Registration page loads in the transition flow even if the account is verified

screencast:  http://screencast.com/t/wAS79Vbqd

reproducible on dev and stage.
We updated the requirement for Persona accounts to be accounts that have signed in since April 30th, 2014 (a couple weeks after the AMO/Marketplace split). If an account is created with FxA though it isn't treated as FxA because it doesn't meet the recent login requirement. We should treat any FxA account as FxA regardless of last login time.

See https://github.com/mozilla/zamboni/blob/42f7d84fed3b420327298686d99e8d0de2f0412d/mkt/account/views.py#L138.
Assignee: nobody → mstriemer
Actually we have no way of knowing the account exists. We don't create the UserProfile record until the user logs in.

If you leave the popup open from creating the account and you verify the email then you will be signed in once the email is verified. Subsequent sign in attempts will take you to FxA sign in as expected.

If FxA implements the API to check if an account exists then we can do something, but we'll have to wait for that and I'm not sure there's much value there.

Comment 3

4 years ago
Based on chat with ckarlof, it sounds like this might be happening on the FxA end of things. If that's wrong, please assign back to us.
Assignee: mstriemer → nobody
Component: Consumer Pages → Server: Firefox Accounts
Product: Marketplace → Mozilla Services
Version: 1.4 → other

Updated

4 years ago
Blocks: 1088604
No longer blocks: 1007956
I'm inclined to resolve this as WONTFIX because this is only an issue during migration, and only an issue for users with an existing FxA but haven't used it at Marketplace yet.

Thoughts, Andy?

Comment 5

4 years ago
Sorry for missing your comments Chris. The transition flow is now turned off, so this bug got closed by attrition.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.