Closed Bug 1096770 Opened 7 years ago Closed 7 years ago

[SHB] Opening new tab in browser makes SHB overlap app window

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1097359
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- unaffected

People

(Reporter: mikehenrty, Assigned: gduan)

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

STR:

1.) Flash build 20141110161200
2.) Open browser app
3.) Open any page
4.) Long press on any link and open in new tab

Expected result:
The new tab browser app window will not be overlayed by SHB, and so you can scroll all the way to the bottom of the page and see all content.

Actual results:
Content on the bottom of the page (as well as the scroll bar) is overlayed by content.
[Blocking Requested - why for this release]:
Inconsistent and confusing UI, content on browser can be hidden by SHB.
blocking-b2g: --- → 2.1?
Alive, any idea what is going on here?
Flags: needinfo?(alive)
I cannot repro with master.

Have you observed shb is disabled? Is it disabled but still shown(css rule issue)?
Flags: needinfo?(alive)
User can't see the bottom of the page.
blocking-b2g: 2.1? → 2.1+
need info on marcia to try to reproduce.
blocking-b2g: 2.1+ → 2.1?
Flags: needinfo?(mozillamarcia.knous)
User can't see content.
blocking-b2g: 2.1? → 2.1+
Attached image 1096770-SHB-overlay.png
Able to reproduce on today's 2.1 build but not on 2.2.

Steps to reproduce
1. Go to Settings > Device Information and enable the Developer menu.
2. Go to Settings > Developer and enable the Software Home Button (SHB).
3. Tap on the SHB to go to the Home Screen.
4. Tap inside the RocketBar to bring up the keyboard.
5. Type "reddit" and then tap on the Search button on the keyboard to launch a Google search for the term "reddit".
6. On the Google search results page, long press on the first link to launch the reddit.com web page.
7. Scroll all the way to the bottom.

Expected Results
The footer should be clearly visible above the Software Home Button (SHB).

Actual Results
The footer appears cut off because the Software Home Button (SHB) is overlaid on top of the footer (see screenshot attached).

Steps to reproduce (continued)
8. Go to Settings > Developer and disable the Software Home Button (SHB).
9. Long press the Home button to bring up the Card View and swipe till you see the window for the reddit.com web page.
10. Tap on the thumbnail for the reddit.com web page to maximize the browser window.
11. Scroll all the way to the bottom.

Expected Results
The footer should be clearly visible.

Actual Results
The footer is clearly visible.


Test Environment for 2.1
Gaia-Rev        4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b9849b3c6aaa
Build-ID        20141112001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:59:42 CST 2014
Bootloader      L1TC10011880


Test Environment for 2.2
Gaia-Rev        5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/688f821edcd4
Build-ID        20141112040208
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 20
Flags: needinfo?(mozillamarcia.knous)
Can we get a reverse regression window to see how this got fixed?
QA Contact: jmercado
Alive, assign to you first. After QA get the regression window, you can check if you can work on this.
Assignee: nobody → alive
Bug 1062437 seems to be the fix of this issue.

Mozilla-inbound Reverse Regression Window

Last Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140904140137
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: 1c0889637e60
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140904140640
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: eb7169690808
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Broken gaia / First Working gecko - ssue does NOT occur
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: eb7169690808

First Working gaia / Last Broken gecko - Issue DOES occur
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: 1c0889637e60

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1c0889637e60&tochange=eb7169690808
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
This was fixed in 2.2 by Bug 1062437 - Patch Author was Botond Ballo - Bug is already assigned to Alive so will NI him instead.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(alive)
QA Contact: jmercado
Could we uplift bug 1062437? It's platform issue and I cannot ask approval for the author.
Flags: needinfo?(alive)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062437
To clarify: I didn't work on this bug but dupe it to bug 1062437 because comment 11.
And even it is not dupe from my experience this one is not a gaia issue I believe.

Deassign myself.
Assignee: alive → nobody
We should make sure that bug 1062437 did indeed fix this. Adding qawanted verifyme to that effect.
Keywords: qawanted, verifyme
(In reply to Michael Henretty [:mhenretty] from comment #15)
> We should make sure that bug 1062437 did indeed fix this. Adding qawanted
> verifyme to that effect.

Michael - bug 1062437 was what fixed this issue in 2.2; that patch was never uplifted to 2.1 so this bug is still affected in 2.1 

No idea why it was marked as a dupe and I'll just NI the patch author now to see about getting it uplifted.
Status: RESOLVED → REOPENED
Flags: needinfo?(botond)
Keywords: qawanted, verifyme
Resolution: DUPLICATE → ---
Upon closer inspection it looks like it was uplifted at https://bugzilla.mozilla.org/show_bug.cgi?id=1062437#c14

Not sure now. I'll have QA-Wanted recheck this issue in the latest 2.1 to make sure it still repro's there for starters.
Keywords: qawanted
Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.1 KK

Actual Results: Software Home button is partially covering up the the text at the bottom of websites such as www.reddit.com

Repro Rate: 2/2

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141120061604
Gaia: 66e6a55892d2c5843d32ebbb63795d2d56892613
Gecko: 6582202c75ca
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Thanks Michael for catching this! We need to get better at tracking those issues.
Alive, Tim, can you take care of this?
Flags: needinfo?(timdream)
Flags: needinfo?(alive)
As Joshua said in comment 14, bug 1062437 has in fact been uplifted to 2.1, so if we still see this then it's not a duplicate.
Flags: needinfo?(botond)
okay, so Botond - it seems like the patch from bug 1062437 was able to fix THIS issue in 2.2 but the uplift on that bug to 2.1 was different enough to NOT fix THIS issue in 2.1
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to Joshua Mitchell [:Joshua_M] from comment #21)
> okay, so Botond - it seems like the patch from bug 1062437 was able to fix
> THIS issue in 2.2 but the uplift on that bug to 2.1 was different enough to
> NOT fix THIS issue in 2.1

My guess would be that this was fixed by a different bug that landed on 2.2 but was not uplifted to 2.1.
hmmmmm.  It was the only bug in our 'fixed' push-log.  I'll re-tag this with Regression-window wanted and get a 2nd opinion on this reverse regression-window.
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
(In reply to Joshua Mitchell [:Joshua_M] from comment #23)
> hmmmmm.  It was the only bug in our 'fixed' push-log.  I'll re-tag this with
> Regression-window wanted and get a 2nd opinion on this reverse
> regression-window.

It's possible that two different fixes are required to fix the STR: one which landed in 2.2 first and was not uplifted to 2.1, and one which landed in 2.2 after the first and was uplifted. Then a reverse regression window on 2.2 would find the second fix, since the first alone is not enough to fix the STR.

In such a case, the first fix can be found by doing a reverse regression window on 2.2 with the second fix applied at each point; however, that is likely to be quite time consuming. It might just make more sense to debug the issue on 2.1.
I've confirmed that the window on comment 10 is indeed the window in Central in which the bug was fixed.

I did notice that on the Last Broken build, the bug would reproduce REGARDLESS of SHB enabled or not, and on the First Working build, bug would NOT reproduce regardless of SHB status. Maybe something else was implemented between these two builds? In any case I agree with comment 24 that debugging this issue on 2.1 makes more sense.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: pcheng
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Could you help?
Flags: needinfo?(timdream)
Flags: needinfo?(gduan)
Flags: needinfo?(alive)
Assignee: nobody → gduan
Flags: needinfo?(gduan)
bug 1097359 also fix it.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1097359
Thanks George! Lets ask QA to verify once we have a build with the patch.
Keywords: verifyme
verified and fixed with today's v2.1 gaia/gecko
Gaia-Rev        18e02f16972f9d54931d57b13f35d2a2c0eda683
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/671e28afeeec
Build-ID        20141124161201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141124.194416
FW-Date         Mon Nov 24 19:44:27 EST 2014
Bootloader      L1TC10011880
You need to log in before you can comment on or make changes to this bug.