Closed Bug 1096846 Opened 5 years ago Closed 4 years ago

Crash in CreateTexture2D @ nvwgf2umx.dll@0x27d3be after video driver restart (Timeout Detection and Recovery - TDR)

Categories

(Thunderbird :: General, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: martin, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141110030204

Steps to reproduce:

Re-Logon to Windows after a few hours 



Actual results:

Screen Flicker -> TB Crash




Expected results:

Thunderbird should have continued running.

Windows Eventlog shows :
Protokollname: System
Quelle:        Display
Datum:         11.11.2014 01:01:17
Ereignis-ID:   4101
Aufgabenkategorie:Keine
Ebene:         Warnung
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      Lakonien
Beschreibung:
Der Anzeigetreiber "nvlddmkm" reagiert nicht mehr und wurde wiederhergestellt.
Ereignis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Display" />
    <EventID Qualifiers="0">4101</EventID>
    <Level>3</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-11-11T00:01:17.000000000Z" />
    <EventRecordID>235111</EventRecordID>
    <Channel>System</Channel>
    <Computer>Lakonien</Computer>
    <Security />
  </System>
  <EventData>
    <Data>nvlddmkm</Data>
    <Data>
    </Data>
  </EventData>
</Event>

I believe this is caused by the same root cause as  bug 1089454 which I reported for the current firefox nightly builds.
.
My take on it: Windows 8.1 has a feature called TDR which may restart the video driver (any not just nvidia as in my case) which makes Thunderbird and Firefox crash.

What should happen is that both products recover gracefully from a Windows video driver restart triggered by TDR.

Reproducible: Always on Application Build ID 	20141107030200 after a video driver restart message in windows eventlog as documented above
Severity: normal → major
Hardware: x86 → x86_64
What's your crash ID?
see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
Severity: major → critical
Component: Untriaged → General
Depends on: 1089454
Flags: needinfo?(martin)
Keywords: crash
Uups sorry it is crash bp-e8da8805-7b6b-4e06-b364-a34a22141111
Flags: needinfo?(martin)
Searching breakpad for CreateTexture2D turns up more reports that may be related.
(Aside: I think I entered a comment and email, seems that did not make it to breakpad, is that a bug in crashreporter)
(In reply to martin from comment #2)
> Uups sorry it is crash bp-e8da8805-7b6b-4e06-b364-a34a22141111

This is  nvwgf2umx.dll@0x27d3be  https://crash-stats.mozilla.com/report/index/e8da8805-7b6b-4e06-b364-a34a22141111   ... Very few of these crashes in the system.

(In reply to martin from comment #3)
> (Aside: I think I entered a comment and email, seems that did not make it to
> breakpad, is that a bug in crashreporter)

As best I can tell, your firefox crashes have your address. But your thunderbird ones do not.  You'll need to add it.  (email addresses are not public, so  https://crash-stats.mozilla.com/report/index/e8da8805-7b6b-4e06-b364-a34a22141111  won't show it to you.  But I can see them)
If my theory is correct then all those crashes in DirectX are related to Windows TDR.
(as written in the referenced bug 1089454 

Seaching BP for CreateTexture2D turns up 14 in Thunderbird

https://crash-stats.mozilla.com/query/?product=Thunderbird&version=ALL%3AALL&platform=win&range_value=30&range_unit=days&date=11%2F11%2F2014+22%3A00%3A00&query_search=signature&query_type=contains&query=CreateTexture2D&reason=&release_channels=&build_id=&process_type=any&hang_type=any

Searching BP for D2D_RECT_F const*, ID2D1Brush* turns up 67
https://crash-stats.mozilla.com/query/?product=Thunderbird&version=ALL%3AALL&platform=win&range_value=30&range_unit=days&date=11%2F11%2F2014+22%3A00%3A00&query_search=signature&query_type=contains&query=D2D_RECT_F+const*%2C+ID2D1Brush*&reason=&release_channels=&build_id=&process_type=any&hang_type=any

(I have looked through the local crashreporter directory and found in the log:
[11/11/14 06:49:10] Crash report submission failed: Der Vorgang wurde erfolgreich beendet.
Which is kind of ambigous, tells me submission failed and then in german "The process was completed sucessfully" 
Seems that upload was partially sucessful since my data is on BP, but it's missing my comments & email, can I add those after upload? )
Since bug 1154003 is fixed, have you crashed Thunderbird 38/Firefox 38?
Status: UNCONFIRMED → NEW
Crash Signature: [@ nvwgf2umx.dll@0x27d3be ]
Ever confirmed: true
Flags: needinfo?(martin)
Summary: Crash in CreateTexture2D after video driver restart → Crash in CreateTexture2D @ nvwgf2umx.dll@0x27d3be after video driver restart (Timeout Detection and Recovery - TDR)
trying to reach Martin - no luck so far
See Also: → 1131879
Whiteboard: [closeme 2015-08-20]
Blocks: tb-hwa
reports on crash-stats are rare, and only with Thunderbird nightly. For example bp-4369ae39-bc48-43f9-8846-ff5392150910.

If this is fixed by bug 1162520 as ashughes suggests then this should be gone in version 38.
Martin unfortuantely has not responded to confirm. Marking WFM until we hear otherwise
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(martin)
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2015-08-20]
You need to log in before you can comment on or make changes to this bug.