Closed Bug 1096871 Opened 7 years ago Closed 7 years ago

[Flame][Settings]You can't copy file to internal storage on MTP mode.

Categories

(Firefox OS Graveyard :: MTP/UMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1107146
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: liuke, Unassigned)

References

Details

Attachments

(2 files)

Attached file logcat_1651.txt
[1.Description]:
[Flame][v2.1][Settings]You can't copy file to internal storage on MTP mode.
Found time:16:51
See attachment:1651.mp4 and logcat_1651.txt

[2.Testing Steps]: 
1. Toggle the USB Storage option to enabled and select MTP protocol 
2. Plug the phone into the Windows Desktop/Laptop 
>> The Phone's USB Disk Drive is detected by the Windows Desktop/Laptop 
3. Using the file manager, navigate to the internal storage directory on the USB storage 
4. Copy the Video, Image, and Music files into the internal storage folder 

[3.Expected Result]: 
4.The file can be copied to device successfully.

[4.Actual Result]: 
4.When you copy file to internal storage, the can't copy box will pop up in PC.

[5.Reproduction build]: 
Gaia-Rev        0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/97487a2d1ee6
Build-ID        20141110001201
Version         34.0

[6.Reproduction Frequency]: 
occasionally Recurrence,3/5
Attached video 1651.MP4
This bug has been verified to fail on Flame 2.1, 2.2.
Issue steps:
1. Toggle the USB Storage option to enabled and select MTP protocol 
2. Plug the phone into the Windows Desktop/Laptop 
>> The Phone's USB Disk Drive is detected by the Windows Desktop/Laptop 

3. Using the file manager, navigate to the internal storage directory on the USB storage 
4. Copy the Video, Image, and Music files into the internal storage folder 

[3.Expected Result]: 
4.The file can be copied to device successfully.

[4.Actual Result]: 
4.When you copy file to internal storage, the can't copy box will pop up in PC.

Found time: 15:22
See attachment: 1552.MP4 and logcat_1552.txt
Reproducing rate: 3/5

Flame 2.1 version:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ea426e47bfc4
Build-ID        20141228001253
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141228.034827
FW-Date         Sun Dec 28 03:48:38 EST 2014
Bootloader      L1TC00011880

Flame 2.2 version:
Gaia-Rev        3554ea9504046646b4679e3a61317c49fc55ca87
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67c42c076393
Build-ID        20141228010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141228.045435
FW-Date         Sun Dec 28 04:54:46 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(hlu)
Hi Alison, Could you help with this, thanks.
Flags: needinfo?(hlu) → needinfo?(ashiue)
Add RD in CC list.
Hi developers, could you please help to check this issue? Except the first time operation, it easily occurs the windows error when copied files from PC to SD card.
Component: Gaia::Settings → MTP/UMS
Flags: needinfo?(ashiue)
Add RD in CC list.
Hi developers, could you please help to check this issue? Except the first time operation, it easily occurs the windows error when copied files from PC to SD card.
QA Whiteboard: [COM=MTP/UMS]
After checking the following logs, I think the root cause is similar to bug 1107146.
This should be a duplicate bug as bug 1107146.

01-04 22:48:44.570   209  2356 I MozMtp  : beginSendObject: Handle: 0x00000028 Parent: 0xffffffff Path: '/storage/sdcard/3-2.jpg'
01-04 22:48:44.570   209  2356 I MozMtp  : endSendObject: Handle: 0x00000028 Path: '/storage/sdcard/3-2.jpg'
01-04 22:48:44.570   209   209 I Gecko   : DSF (parent) file-watcher-update: mStorageType 'sdcard' mStorageName 'sdcard' mRootDir '' mPath '3-2.jpg' mFile->GetPath '/storage/sdcard/3-2.jpg'
01-04 22:48:44.570   209   209 I MozMtp  : Observe: file-watcher-update: file 3-2.jpg modified
01-04 22:48:44.570   209  2356 I MozMtp  : getObjectList: StorageID: 0x00010001 Format: 0x0000 Parent: 0xffffffff
01-04 22:48:44.570   209  2356 I MozMtp  : getObjectList:   returning 9 items
01-04 22:48:44.580   209   209 I Gecko   : DSF (parent) file-watcher-update: mStorageType 'sdcard' mStorageName 'sdcard' mRootDir '' mPath '3-2.jpg' mFile->GetPath '/storage/sdcard/3-2.jpg'
01-04 22:48:44.580   209   209 I MozMtp  : Observe: file-watcher-update: file 3-2.jpg modified
01-04 22:48:44.580   209   209 I Gecko   : DSF (parent) file-watcher-update: mStorageType 'sdcard' mStorageName 'sdcard' mRootDir '' mPath '3-2.jpg' mFile->GetPath '/storage/sdcard/3-2.jpg'
01-04 22:48:44.580   209   209 I MozMtp  : Observe: file-watcher-update: file 3-2.jpg modified
01-04 22:48:44.580   209   209 I Gecko   : DSF (parent) file-watcher-update: mStorageType 'pictures' mStorageName 'sdcard' mRootDir '' mPath '3-2.jpg' mFile->GetPath '/storage/sdcard/3-2.jpg'
01-04 22:48:44.580   209   209 I MozMtp  : Observe: file-watcher-update: file 3-2.jpg modified
01-04 22:48:44.580   209   209 I Gecko   : DSF (parent) file-watcher-update: mStorageType 'pictures' mStorageName 'sdcard' mRootDir '' mPath '3-2.jpg' mFile->GetPath '/storage/sdcard/3-2.jpg'
01-04 22:48:44.580   209   209 I MozMtp  : Observe: file-watcher-update: file 3-2.jpg modified
01-04 22:48:44.580   209   209 I Gecko   : DSF (parent) file-watcher-update: mStorageType 'pictures' mStorageName 'sdcard' mRootDir '' mPath '3-2.jpg' mFile->GetPath '/storage/sdcard/3-2.jpg'
01-04 22:48:44.580   209   209 I MozMtp  : Observe: file-watcher-update: file 3-2.jpg modified
01-04 22:48:44.580   209  2531 I MozMtp  : FileWatcherUpdate: file /storage/sdcard/3-2.jpg modified
01-04 22:48:44.580   209  2531 I MozMtp  : FileWatcherUpdate: About to call sendObjectRemoved Handle 0x00000028 file /storage/sdcard/3-2.jpg
01-04 22:48:44.580   209  2532 I MozMtp  : FileWatcherUpdate: file /storage/sdcard/3-2.jpg modified
01-04 22:48:44.580   209  2532 I MozMtp  : FileWatcherUpdate: file /storage/sdcard/3-2.jpg modified
01-04 22:48:44.580   209  2533 I MozMtp  : FileWatcherUpdate: file /storage/sdcard/3-2.jpg modified
01-04 22:48:44.580   209  2533 I MozMtp  : FileWatcherUpdate: file /storage/sdcard/3-2.jpg modified
01-04 22:48:44.580   209  2531 I MozMtp  : CreateEntryForFileAndNotify: About to call sendObjectAdded Handle 0x00000029 file /storage/sdcard/3-2.jpg
01-04 22:48:44.580   209  2531 I MozMtp  : FileWatcherUpdate: file /storage/sdcard/3-2.jpg modified
01-04 22:48:44.580   209  2531 I MozMtp  : FileWatcherUpdate: About to call sendObjectRemoved Handle 0x00000029 file /storage/sdcard/3-2.jpg
01-04 22:48:44.580   209  2531 I MozMtp  : CreateEntryForFileAndNotify: About to call sendObjectAdded Handle 0x0000002a file /storage/sdcard/3-2.jpg
01-04 22:48:44.580   209  2356 E MozMtp  : getObjectInfo: Handle 0x00000028 is invalid
01-04 22:48:44.580   209  2356 E MozMtp  : getObjectInfo: Handle 0x00000028 is invalid
Flags: needinfo?(echuang)
I create a patch in https://bug1107146.bugzilla.mozilla.org/attachment.cgi?id=8543877.
After verification, it can solve this problem.
Depends on: 1107146
Flags: needinfo?(echuang)
This bug can be fixed by the patch in bug 1107146.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107146
QA Whiteboard: [COM=MTP/UMS]
You need to log in before you can comment on or make changes to this bug.