If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Call log is showing wrong number of calls

RESOLVED DUPLICATE of bug 1094960

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1094960
3 years ago
3 years ago

People

(Reporter: viorela, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
The number of calls are sometimes displayed erroneously in Call log section.
It's difficult to make 2 consecutive calls to the same phone number, without getting the number of calls displayed wrong.

This issue is reproducible manually, intermittently.
Reprod rate - 4 out of 5

#STR:
1. Launch Dialer app
2. Type a phone number
3. Tap Call button
4. Tap Hang up button
5. Tap Call log button 

#Expected results:
There's only one call made to that number displayed in 'All' section - E.g: 0000-000-000

#Actual results:
There are 2 calls made to that number displayed in 'All' section - E.g: 0000-000-000 (2)

Note: If there's only one call displayed (as it is expected), and I call the same phone number again, then check the Call log, there are 3 calls made to that number displayed, instead of two - 0000-000-000 (3)

Build info: 
Gaia-Rev        e02facadb0bc3fe32227b52b31ca47822f7f4322
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c0d559389a5c
Build-ID        20141110160207
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141110.192705
FW-Date         Mon Nov 10 19:27:22 EST 2014
Bootloader      L1TC10011880
(Reporter)

Comment 1

3 years ago
Created attachment 8520606 [details]
logcat
(Reporter)

Comment 2

3 years ago
Video of the issue: https://www.dropbox.com/s/gvpm1u5f9tcpq14/VID.3gp?dl=0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094960
You need to log in before you can comment on or make changes to this bug.