HTML to plain/text Conversion cuts off before body text

VERIFIED WORKSFORME

Status

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
3 years ago

People

(Reporter: nbaca, Assigned: rhp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

Build 1999072823M9/Necko: Win32/NT4

Overview Description: In plain text mode reply to a message and send it. View
the message and notice that the original text is gone.

Steps to Reproduce:
1. Launch Mail
2. Select a message and select the Reply button.
3. Notice the text that is from the original message.
4. Type additional text and send the message.
5. View the message on the recipients system.
6. Note what text is in the message body.


Actual Results:The original text is gone. Only the new text appears.

Expected Results:The original text and new text should display.

Additional Builds and Platforms Tested On:
- Using HTML it displays the original and new text.
- Using plain text the same results appear using the Mac 7/29 and Linux 7/30
build.
Assignee: gagan → mscott
Component: Necko → Networking-Mail
OS: Windows NT → All
QA Contact: lchiang → esther
Assignee: mscott → rhp
Re-assigning to rhp as this is his area.

Rich, I may have broken this during the necko landing??
Status: NEW → ASSIGNED
Target Milestone: M9
This is actually a quoting problem...the original message is not being quoted
correctly. Nothing new here...just have to figure out what is failing.

- rhp
*** Bug 9736 has been marked as a duplicate of this bug. ***
Summary: Reply using plain text and original text is gone → HTML to plain/text Conversion cuts off before body text
Target Milestone: M9 → M10
This is dependent on a rework on the quoting API and plain text editor. This
still seem to be operational.

- rhp
Bulk move rhp bugs to M11 for now
Whiteboard: [PR1]
I think this needs to be fixed for PR1, so I added a note to the Status
Whiteboard
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Quoting seems to work now. Marking worksforme.
Status: RESOLVED → VERIFIED
Build 1999092309M11: Win32/NT4, Linux/Redhat 5.0, Mac 8.5.1
Verified Fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.