If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Persona sign-in incorrectly drops users off at account linking

RESOLVED WONTFIX

Status

Mozilla Developer Network
Sign-in
--
minor
RESOLVED WONTFIX
3 years ago
7 months ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
via Justin...

What did you do?
================

1. Sign in with a Persona account that is not tied to an MDN account.
2. Arrive on the "Create your MDN profile to continue" page.
3. Instead of submitting the form, use the "Sign in" button in the
   header to sign in again, this time with a Persona account that *is*
   tied to an MDN account.

What happened?
==============
Arrived on the "Account connections" page.

What should have happened?
==========================
Arrive on the "Create your MDN profile to continue" page as if Steps 1
and 2 never happened.
Flags: needinfo?(shobson)
Flags: needinfo?(lcrouch)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1093887
I think if you sign in with an account that *is* tied to an MDN account (step 3 in comment 0) then the appropriate action will *not* be to land on the "Create a profile to continue" page. In fact I think the appropriate action is to land users on whatever page they first clicked "sign in from", and if that's too hard, to land them on the front page.
(Reporter)

Comment 3

3 years ago
Great catch. You're absolutely right.

The correct effect is to return the user to the page they started out on (the page they were on before performing Step 1) or if nothing else, to return the user to the homepage.
Severity: normal → minor
I agree with Justin about the intended behaviour.
Flags: needinfo?(shobson)
Clearing my needinfo? ... does this need anything else before it can be worked?
Flags: needinfo?(lcrouch)
(Reporter)

Comment 6

3 years ago
(In reply to Luke Crouch [:groovecoder] from comment #5)
> Clearing my needinfo? ... does this need anything else before it can be
> worked?

I don't think so. The needinfo flags were copied from an earlier bug, but don't apply any longer.
Persona is no more.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.