Cannot type anymore some accented letters like "ê" in trunk builds since landing of bug #1040653

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: fredbezies, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Very simple bug to reproduce. On my french keyboard, when I want to enter "ê" in a text, I only got an empty space.

But when I go to browser console, I got this error in browser console :

KeyboardEvent.key values starting with "Dead" are obsolete and will be merged into just "Dead". For more help https://developer.mozilla.org/en-US/docs/Web/API/KeyboardEvent.key

I will look at tinderbox and find when it stopped working.
(Reporter)

Updated

4 years ago
Summary: Cannot type anymore some accented letters like ê in trunk builds : "KeyboardEvent.key values starting with "Dead" are obsolete" message in browser console → Cannot type anymore some accented letters like "ê" in trunk builds : "KeyboardEvent.key values starting with "Dead" are obsolete" message in browser console
The warning was added in bug 1024864.

Is this really a trunk only issue? Or if this is, are you perhaps using E10s?
(See Preferences->General->Enabled E10s)
(Reporter)

Comment 2

4 years ago
Only a trunk issue. It doesn't change anything to have e10s on or off.
(Reporter)

Comment 3

4 years ago
Got a regression window :

20141110041657
https://hg.mozilla.org/mozilla-central/rev/776f65ae74c6 => ok

20141110053357
https://hg.mozilla.org/mozilla-central/rev/c0d559389a5c => busted

So, what is preventing letters like "ê" to be typed ?
(Reporter)

Comment 4

4 years ago
I tried with a clean profile : e10s seems to be guilty. So, I think it could be related to this bug ?

https://bugzilla.mozilla.org/show_bug.cgi?id=1040653

I will try removing patch from it, rebuild Mozilla Firefox and report results here.
(Reporter)

Comment 5

4 years ago
When I try to revert patch for bug 1040653, I got this error message :

patch -R < e10s-eyedropper.patch 
The next patch, when reversed, would delete the file eyedropper-child.js,
which does not exist!  Ignore -R? [n] n
Apply anyway? [n] y
patching file eyedropper-child.js
Unreversed patch detected!  Ignore -R? [n] n
Apply anyway? [n] y
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file eyedropper-child.js.rej
can't find file to patch at input line 34
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/browser/devtools/eyedropper/eyedropper.js b/browser/devtools/eyedropper/eyedropper.js
|--- a/browser/devtools/eyedropper/eyedropper.js
|+++ b/browser/devtools/eyedropper/eyedropper.js
--------------------------

Kinda stuck here. Any idea ?
Don't use patch -R but hg update -r <the revision you want> ?
Or are missing -p1. Should it be patch -R -p1 < e10s-eyedropper.patch 

But have you found the regression range using Nightlies?
What is the last Nightly which did work, and what is the first one which doesn't work.
about:buildconfig should then give you the hg revisions of those.
(Reporter)

Comment 8

4 years ago
(In reply to Olli Pettay [:smaug] from comment #6)
> Don't use patch -R but hg update -r <the revision you want> ?
> Or are missing -p1. Should it be patch -R -p1 < e10s-eyedropper.patch 
> 
> But have you found the regression range using Nightlies?

Both nightlies and tinderbox builds. Which gave me the regression range.

> What is the last Nightly which did work, and what is the first one which
> doesn't work.

Last working : 20141110030204
https://hg.mozilla.org/mozilla-central/rev/d380166816dd

First broken : 20141111030203
https://hg.mozilla.org/mozilla-central/rev/cbe6afcae26c

> about:buildconfig should then give you the hg revisions of those.

I found it was a really recent regression, so I looked at tinderbox builds, and found last working and first broken one, as I reported earlier.

I tried with a clean profile, and it is broken, even if I activate or not e10s.
(Reporter)

Comment 9

4 years ago
Removing patch for bug 1040653 fixes this bug, now I can again type "ê" without problem.

What is preventing keystrokes in this patch ?
(Reporter)

Updated

4 years ago
Depends on: 1040653
(Reporter)

Updated

4 years ago
Summary: Cannot type anymore some accented letters like "ê" in trunk builds : "KeyboardEvent.key values starting with "Dead" are obsolete" message in browser console → Cannot type anymore some accented letters like "ê" in trunk builds since landing of bug #1040653

Updated

4 years ago
Duplicate of this bug: 1098005

Comment 11

4 years ago
Heather, can you have a look, please? :-)
Flags: needinfo?(fayearthur)
Keywords: regression

Updated

4 years ago
Duplicate of this bug: 1098271

Updated

4 years ago
Duplicate of this bug: 1098309
Duplicate of this bug: 1097817
I'm looking into this. I can't reproduce it right now. Anyone have tips? I'm on a Mac right now, and this is what I'm doing:

1. Set language to French in System Prefs > Language and Text > Input Sources > French.
2. Type Opt+a in url bar

All the accent keys seem to work for me.
Flags: needinfo?(fayearthur)
This bug is about dead keys; modifier keys are not affected.
I confirm this bug affects me on Linux.

Steps to Reproduce
------------------
1. Set your keyboard layout to French or any other layout with dead keys;
2. Open Nightly;
3. Press '^';
4. Press 'e'.

What happens
------------
Nothing is outputted

What should happen
------------------
Character 'ê' should be outputted

Comment 17

4 years ago
I am able to type "Côtes du Rhône" without difficulty using a French keyboard with dead keys in Nightly. I am running Fedora 19.
(Reporter)

Comment 18

4 years ago
(In reply to Jim Blandy :jimb from comment #17)
> I am able to type "Côtes du Rhône" without difficulty using a French
> keyboard with dead keys in Nightly. I am running Fedora 19.

32 or 64 bits Fedora 19 ?
(In reply to Frederic Bezies from comment #18)
> (In reply to Jim Blandy :jimb from comment #17)
> > I am able to type "Côtes du Rhône" without difficulty using a French
> > keyboard with dead keys in Nightly. I am running Fedora 19.
> 
> 32 or 64 bits Fedora 19 ?

FYI, this bug I hit before seems to be fixed now on most recent nightly
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
36.0a1 (2014-11-13)
(Reporter)

Comment 20

4 years ago
Seems to be fixed with this nightly based on https://hg.mozilla.org/mozilla-central/rev/ab137ddd3746. But what fixes it ?!
Fwiw, I can't see bug 1040653 having anything to do with this problem.

Comment 22

4 years ago
Sounds like it works now, whatever it was!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141113003001 c-c:c3c1bc2ecb51 m-c:ab137ddd3746

I confirm that I had the same problem with yesterday's trunk build of SeaMonkey (dead keys didn't work, neither in browser textareas nor in mailer outgoing mails; the accented characters precomposed on single keys of my Belgian keyboard were not affected).

The problem has disappeared in today's build (shown at the top of this comment)

Gijs, on which build did you test this? I suppose that at least one Firefox test on non-Linux would be needed, together with my L64 SeaMonkey test, before we could set VERIFIED.
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: verifyme

Comment 24

4 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #23)
> Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
> SeaMonkey/2.33a1 ID:20141113003001 c-c:c3c1bc2ecb51 m-c:ab137ddd3746
> 
> I confirm that I had the same problem with yesterday's trunk build of
> SeaMonkey (dead keys didn't work, neither in browser textareas nor in mailer
> outgoing mails; the accented characters precomposed on single keys of my
> Belgian keyboard were not affected).
> 
> The problem has disappeared in today's build (shown at the top of this
> comment)
> 
> Gijs, on which build did you test this? I suppose that at least one Firefox
> test on non-Linux would be needed, together with my L64 SeaMonkey test,
> before we could set VERIFIED.

I'm going by the 5-6 comments (including from the bugreporter(s)) that say it's fixed now, that is all.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to :Gijs Kruitbosch from comment #24)
> (In reply to Tony Mechelynck [:tonymec] from comment #23)
> > Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
> > SeaMonkey/2.33a1 ID:20141113003001 c-c:c3c1bc2ecb51 m-c:ab137ddd3746
> > 
> > I confirm that I had the same problem with yesterday's trunk build of
> > SeaMonkey (dead keys didn't work, neither in browser textareas nor in mailer
> > outgoing mails; the accented characters precomposed on single keys of my
> > Belgian keyboard were not affected).
> > 
> > The problem has disappeared in today's build (shown at the top of this
> > comment)
> > 
> > Gijs, on which build did you test this? I suppose that at least one Firefox
> > test on non-Linux would be needed, together with my L64 SeaMonkey test,
> > before we could set VERIFIED.
> 
> I'm going by the 5-6 comments (including from the bugreporter(s)) that say
> it's fixed now, that is all.

Ah, OK.
Status: RESOLVED → VERIFIED
Keywords: verifyme

Comment 26

4 years ago
(In reply to Frederic Bezies from comment #18)
> (In reply to Jim Blandy :jimb from comment #17)
> > I am able to type "Côtes du Rhône" without difficulty using a French
> > keyboard with dead keys in Nightly. I am running Fedora 19.
> 
> 32 or 64 bits Fedora 19 ?

64-bit.
You need to log in before you can comment on or make changes to this bug.