Closed Bug 1097196 Opened 7 years ago Closed 7 years ago

Skate overscroll animates from wrong direction

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1093298

People

(Reporter: gbrander, Unassigned)

References

Details

There is a bug with the new overscroll effect (bug 1066888).

The "tug" effect works correctly:

- Open scrollable view (email is a good example because it's easy to spot)
- Scroll to top, then tug scrollable view "beyond" top and release.
- Scrolling layer stretches, then bounces. Top of scrolling layer remains flush with edge of scrollable viewport.

But the fling overscroll effect does not:

- Pan down a ways from top
- Scroll quickly to gain momentum
- Bug: scrolling layer skates, hits top. Top of scrolling layer *does not* remain flush with top of scrollable viewport. Instead, a white gap is revealed during animation.

Expected:
Animations for skate and tug should match.
Ah, turns out we already have a bug on this! Actually two bugs. Collapsing into bug 1093298.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1093298
You need to log in before you can comment on or make changes to this bug.