[Camera] Shutter button and Video toggle briefly display text on launch of Camera app.

RESOLVED DUPLICATE of bug 1118981

Status

RESOLVED DUPLICATE of bug 1118981
4 years ago
4 years ago

People

(Reporter: Marty, Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8520859 [details]
log-Camera.txt

Description:
When launching the Camera app, the Shutter button and Video toggle will briefly display text before the graphics for the icons load in.  Both icons display the word 'Camera'
   
Repro Steps:
1) Update a Flame device to BuildID: 20141111040202
2) Launch the Camera app.
3) Observe the icons at the bottom of the screen as they load in.
  
Actual:
Camera button icons display text during app start up.
  
Expected: 
Camera button icons display properly during app start up.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141111040202 (Shallow Flash)
Gaia: 6af3a8a833eb8bb651e8b188cb3f3c3a43bb4184
Gecko: 76b85b90a8cb
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Repro frequency: 7/7
See attached: screenshot, video clip (URL), logcat

----------------------------------

This issue does NOT occur on Flame 2.1.
Camera icons display properly during app start up.

Environmental Variables:
Device: Flame 2.1 (319MB)
BuildID: 20141111001201 (Shallow Flash)
Gaia: 7154f9aa0a69af56c8bd89be0c98d9791449527b
Gecko: 452db1a0c9a0
Gonk: 
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Comment 1

4 years ago
Created attachment 8520860 [details]
Camera_Text_Screenshot.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Bad UI regression with a core feature, high visibility (every launch).

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
QA Contact: pcheng
Flags: needinfo?(dmarcos)
Seeing this issue in Smart Collections as well on Flame 2.2 (319mb/shallow flash)

Actual result: The word "Close" briefly displays before the X icon appears when opening a smart collection.

Device: Flame 2.2
BuildID: 20141112040208
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140924201356
Gaia: 03d7bcad57ea281869976a9aed0a38849f7c8bc5
Gecko: c0c410aed86f
Version: 35.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140924201854
Gaia: 03d7bcad57ea281869976a9aed0a38849f7c8bc5
Gecko: a07df88f972e
Version: 35.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Same Gaia so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c0c410aed86f&tochange=a07df88f972e

Caused by bug 998869.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Caused by bug 998869 - can you take a look John?
Blocks: 998869
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(jdaggett)
QA Contact: pcheng

Updated

4 years ago
Component: Gaia::Camera → Graphics: Text
Product: Firefox OS → Core
Wilson, could this be related to the icon font? (See comment #5)
Flags: needinfo?(wilsonpage)
If an icon font is being used and it's loaded via @font-face, it would be helpful to see the output of userfont logging for those two builds, before and after the regression.

export NSPR_LOG_MODULES=userfonts:5,fontdownloader:5
export NSPR_LOG_FILE=/path/to/userfonts.log
Flags: needinfo?(jdaggett)
If we're seeing icon-fonts glyphs that aren't loaded, it means the system-font speed boost is failing. This could be because:

1. The `gaia-icons.ttf` camera is loading doesn't match the `/system/fonts/hidden/gaia-icons.ttf`.
2. Something is broken in Gecko :'(

Comment 5 suggests the latter may be true. Is so, all apps will be suffering performance startup regressions in the range of 50-100ms.
Flags: needinfo?(wilsonpage)
NI :mwu as he implemented the Gecko side of things, and knows a lot more than me about it.
Flags: needinfo?(mwu)
Please try again with full flash and let me know if that works. If it does, this is just an artifact of shallow flashing. (and we should fix our shallow flashing to include these fonts)
Flags: needinfo?(mwu) → needinfo?(mshuman)
I can't actually reproduce this on today's build. I suspect this is a side effect of shallow-flash.
(Reporter)

Comment 12

4 years ago
It looks like you are correct, and this seems to be specific to Shallow Flash, and does NOT occur on Full Flash.

This issue DOES still occur on Flame 2.2 Shallow Flash
Camera button icons display text during app start up.

Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141118040205 (Shallow Flash)
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------

This issue does NOT occur on Flame 2.2 Full Flash.
Camera button icons display properly during app start up.

Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141118040205 (Full Flash)
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(mshuman) → needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Per previous comments this does not sound like a graphics bug, over to Firefox OS.
Component: Graphics: Text → General
Product: Core → Firefox OS
Guessing the cause of this is bug 1118981.
Depends on: 1118981
Once the patch for bug 1118981 lands on trunk, it would be useful to know if that solves the problem noted here.
Flags: needinfo?(mshuman)
(Reporter)

Comment 16

4 years ago
Tested on the latest Flame 3.0 with Shallow Flash .
This issue no longer occurs.

Environmental Variables:
Device: Flame 3.0 Master
BuildID: 20150116010205
Gaia: 401e981f51cf047292d101c785be8ec48bf75e8c
Gecko: cac6192956ab
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(mshuman)
Based on comment 16 I'm assuming this is a dupe of bug 1118981, which has been fixed. Please reopen if this is still occurring.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118981

Updated

4 years ago
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.