Try out how shorter CC slices would work

RESOLVED FIXED in mozilla36

Status

()

Core
XPCOM
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

36 Branch
mozilla36
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Currently the slice time is 10ms, but I think we should try 5ms.
10ms dominates currently CC slice max times.

(Unlinking isn't incremental, so this doesn't affect to that.)
Created attachment 8520883 [details] [diff] [review]
5ms

https://tbpl.mozilla.org/?tree=Try&rev=6ca536f7a616

let's see what tryserver says. Need to look at also perf numbers.
Comment on attachment 8520883 [details] [diff] [review]
5ms

Let's see what telemetry says about this.

Even if this wouldn't help with unlink slices, this should reduce marking slice, which means there is a chance that fewer frames are dropped during painting.
Attachment #8520883 - Flags: review?(continuation)
Attachment #8520883 - Flags: review?(continuation) → review+
https://hg.mozilla.org/mozilla-central/rev/36147782c86e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Duplicate of this bug: 1005685
You need to log in before you can comment on or make changes to this bug.