Disabling "browser.urlbar.autoFill" Has no Effect

UNCONFIRMED
Unassigned

Status

()

Firefox for Android
Awesomescreen
UNCONFIRMED
3 years ago
a year ago

People

(Reporter: deedlefake, Unassigned)

Tracking

33 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20131205075310

Steps to reproduce:

1) Enter "about:config" in the urlbar.
2) Search for "autofill".
3) Set both "brower.urlbar.autoFill" and "browser.urlbar.autofill.typed" to false.
4) Begin typing in the urlbar.


Actual results:

Autofill is still functional, even with both settings disabled.


Expected results:

Autofill should have been non-functional, like in the desktop version of Firefox.
(Reporter)

Updated

3 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 902101
I don't know that this is a dupe of bug 902101. Those prefs look different.

That said, I don't know that we'd ever impl "browser.urlbar.autoFill" since I don't know exactly what it does on desktop.

Also, how is this related to bug 1052595 which added support for "browser.urlbar.autocomplete.enabled"
(Reporter)

Updated

3 years ago
Version: Firefox 36 → Firefox 33
(Reporter)

Comment 3

3 years ago
This is different from both bugs. Bug 902101 is talking about autofill in forms; this bug is about autofill in the urlbar. Bug 1052595, on the other hand, is talking about a setting that completely disables autocomplete.

The urlbar has two types of autocompletion: The dropdown list and autofill. The setting Bug 1052595 is talking about disables the dropdown, but "browser.urlbar.autoFill" disables the autofill, which is where it puts in pre-selected text ahead of the cursor as you type.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.