Closed Bug 1097288 Opened 7 years ago Closed 7 years ago

[FTE] "Show Password" checkbox is indented in FTU when entering a wifi password

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED FIXED
2.1 S9 (21Nov)
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: AdamA, Assigned: mancas)

Details

(Keywords: regression, Whiteboard: [2.2-Daily-Testing][Systemsfe])

Attachments

(5 files)

Attached file logcat
Description:
When the user is connecting to Wi-fi in the FTE/FTU the "Show password" Checkbox will be indented. This is inconsistent with the settings where it is not indented.

Repro Steps:
1) Update a Flame to 20141111040202
2) Proceed through FTE until joining a wifi network
3) Select a wifi network
4) Observe "Show Password" Checkbox

Actual:
The checkbox is indented

Expected:
It is expected that the checkbox is not indented

Environmental Variables:
Device: Flame 2.2
Build ID: 20141111040202 (319mb)(Shallow Flash)
Gaia: 6af3a8a833eb8bb651e8b188cb3f3c3a43bb4184
Gecko: 76b85b90a8cb
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5
See attached: screenshot, logcat
Attached image Indented checkbox
This issue occurs on yesterdays 2.2 Flame.

Environmental Variables:
Device: Flame 2.2
Build ID: 20141110040206 (319mb)(Shallow Flash)
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: d380166816dd
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Result:
The "Show Password" checkbox is indented.
----------------------------------------------------------------------
This issue does not occur in 2.1 Flame.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141111001201 (319mb)(Shallow Flash)
Gaia: 7154f9aa0a69af56c8bd89be0c98d9791449527b
Gecko: 452db1a0c9a0
Version: 34.0 (2.1) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
The "Show Password" checkbox is not indented.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing][Systemsfe]
Seems minor, need info on qa lead for decision.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(mozillamarcia.knous)
Inconsistent UI - need info on Stephany since I am not quite sure who the UX person is for FTE.
blocking-b2g: --- → 2.2?
Flags: needinfo?(mozillamarcia.knous) → needinfo?(swilkes)
Assignee: nobody → b.mcb
Attached file Proposed patch
It seems to be a css issue. could you take a look at the patch when you get a chance, Fernando?

Thanks
Attachment #8522183 - Flags: review?(fernando.campo)
Attached image wifi-password
Flagging Jacqueline on FTE.
Flags: needinfo?(swilkes) → needinfo?(jsavory)
Comment on attachment 8522183 [details] [review]
Proposed patch

thanks for the quick fix Manuel
Attachment #8522183 - Flags: review?(fernando.campo) → review+
The screenshot of the patch looks good to me, its much better without the indent. Thanks!
Flags: needinfo?(jsavory)
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/006aa98685969a04df0f7b88dae92a4c295be1a7
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.