Closed Bug 1097289 Opened 5 years ago Closed 5 years ago

Intermittent e10s REFTEST TEST-UNEXPECTED-PASS | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html | image comparison (==)

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37
Tracking Status
e10s + ---
firefox35 --- wontfix
firefox36 --- wontfix
firefox37 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

12:29:54     INFO -  REFTEST TEST-START | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html
12:29:54     INFO -  REFTEST TEST-LOAD | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html | 4487 / 11439 (39%)
12:29:54     INFO -  JavaScript error: chrome://reftest/content/reftest.js, line 1379: NS_ERROR_FAILURE:
12:29:54     INFO -  REFTEST TEST-LOAD | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4-ref.html | 4487 / 11439 (39%)
12:29:54     INFO -  REFTEST TEST-UNEXPECTED-PASS | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html | image comparison (==)
12:29:54     INFO -  REFTEST   IMAGE: <green...lots of green...>
12:29:54     INFO -  REFTEST INFO | Saved log: START file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
12:29:54     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
12:29:54     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
12:29:54     INFO -  REFTEST INFO | Saved log: Updating canvas for invalidation
12:29:54     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_SPELL_CHECKS
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 169000
12:29:54     INFO -  REFTEST INFO | Saved log: Updating canvas for invalidation
12:29:54     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,169000
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: Completed
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
12:29:54     INFO -  REFTEST INFO | Saved log: RecordResult fired
12:29:54     INFO -  REFTEST INFO | Saved log: START file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4-ref.html
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
12:29:54     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
12:29:54     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
12:29:54     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
12:29:54     INFO -  REFTEST INFO | Saved log: RecordResult fired
12:29:54     INFO -  REFTEST INFO | Loading a blank page
12:29:55     INFO -  REFTEST TEST-END | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/css-gradients/large-gradient-4.html
Duplicate of this bug: 1097425
layout/reftests/css-gradients/reftest.list:
fails-if(browserIsRemote&&!B2G) == large-gradient-4.html large-gradient-4-ref.html

Perhaps just change that to reflect reality?
e10s test issue.
Attached patch Reenable tests (obsolete) — Splinter Review
I suspect bug 1109263 will make this bug perma-happen, by fixing the incorrect failure. If so, this patch can be used to make the expected behaviour match reality.
Attached patch PatchSplinter Review
Strange, only large-gradient-4 is affected. I would have expected large-gradient-3 to be affected as well. Oh well, updating patch for just that one test.
Attachment #8534340 - Attachment is obsolete: true
Attachment #8534343 - Flags: review?(mats) → review+
Assignee: nobody → bugmail.mozilla
https://hg.mozilla.org/mozilla-central/rev/89248cc77519
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.