Last Comment Bug 1097297 - Link to other systems & languages on the Firefox Developer Edition page
: Link to other systems & languages on the Firefox Developer Edition page
Status: RESOLVED FIXED
[kb=1583564]
:
Product: www.mozilla.org
Classification: Other
Component: General (show other bugs)
: Production
: All All
-- normal
: ---
Assigned To: Kohei Yoshino [:kohei]
:
:
Mentors:
: 1117525 (view as bug list)
Depends on: 1101220
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-11 14:33 PST by Fuqiao Xue [:xfq]
Modified: 2015-01-12 10:52 PST (History)
5 users (show)
See Also:
Locale:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
pull request (44 bytes, text/x-github-pull-request)
2014-11-18 16:46 PST, Kohei Yoshino [:kohei]
no flags Details | Review | Splinter Review

Description User image Fuqiao Xue [:xfq] 2014-11-11 14:33:53 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141110004002

Steps to reproduce:

Go to https://www.mozilla.org/en-US/firefox/developer/


Actual results:

I wanted to download Firefox Developer Edition, but not for the system & language I was using. I couldn't find a link to other systems & languages.


Expected results:

Perhaps a link to https://www.mozilla.org/en-US/firefox/aurora/all/ should be added to https://www.mozilla.org/en-US/firefox/developer/ .
Comment 1 User image Jennifer Bertsch [:jbertsch] 2014-11-12 13:43:36 PST
Hi Flod-

What is the localization plan for the Developer Edition product?

Thx,
Jen
Comment 2 User image Francesco Lodolo [:flod] 2014-11-12 23:28:21 PST
It's already localized (bits come from mozilla-aurora, and it replaced Aurora which was localized).

That's also why I'm correctly getting a download for Italian
https://www.mozilla.org/it/firefox/channel/#aurora

Or here
https://www.mozilla.org/it/firefox/developer/

The problem is that we only have 10 or so locales for the landing page. I agree that a link to "Systems & Languages" makes sense.
Comment 3 User image Jennifer Bertsch [:jbertsch] 2014-11-13 09:00:26 PST
Thanks, Flod.  A link to the Aurora page as it is now just with Dev Edition branding?  Or a new Dev Edition page listing the "completed" locales?
Comment 4 User image Francesco Lodolo [:flod] 2014-11-13 09:20:00 PST
https://www.mozilla.org/en-US/firefox/aurora/all/ is currently not localized (as firefox/all), but I'd be fine with a link to that page with the right branding.

Not sure if there's any plan to update the download pages at some point.
Comment 5 User image Kohei Yoshino [:kohei] 2014-11-18 16:46:05 PST
Created attachment 8524989 [details] [review]
pull request

The branding will be updated as part of Bug 1101220.
Comment 6 User image Kohei Yoshino [:kohei] 2015-01-09 11:00:22 PST
*** Bug 1117525 has been marked as a duplicate of this bug. ***
Comment 7 User image [github robot] 2015-01-12 10:52:39 PST
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/8fb68e5141b700cfa8b9d0fa591513ca63f3db33
Fix Bug 1097297 - Link to other systems & languages on the Firefox Developer Edition page

https://github.com/mozilla/bedrock/commit/65620476a145f2ee568a3012b37be20498922ca5
Merge pull request #2518 from kyoshino/bug-1097297-devedition-all

Fix Bug 1097297 - Link to other systems & languages on the Firefox Developer Edition page

Note You need to log in before you can comment on or make changes to this bug.