[Music] When repeatedly tapping the play button, The 'Create Ringtone' will not preview the music

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Ringtones
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Petes, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8520982 [details]
cm.txt

Description:
When repeatedly tapping the play button, The 'Create Ringtone' will not preview the music

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20141111001201
2) Go to music, play a song
3) Share Ringtones
4) Repeatedly tap play


Actual:
'Create Ringtone' music will not play

Expected:
'Create Ringtone' music play

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141111001201
Gaia: 7154f9aa0a69af56c8bd89be0c98d9791449527b
Gecko: 452db1a0c9a0
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=DBhIMc-m1UU
(Reporter)

Comment 1

4 years ago
This issue also occurs on the Flame 2.2 and the Flame 2.0, the 'Create Ringtone' music will not play

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141111040202
Gaia: 6af3a8a833eb8bb651e8b188cb3f3c3a43bb4184
Gecko: 76b85b90a8cb
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141111000205
Gaia: dfdd6268b9784eafdd509f0ddf71407698ed5080
Gecko: fcc5d31f84d7
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)

Comment 2

4 years ago
This works fine for me on 2.2.

Updated

4 years ago
Component: Gaia::Music → Gaia::Ringtones
Not nominating to block on this. The user must rapidly tap the play button 10+ times before this bug occurs.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(Reporter)

Comment 4

4 years ago
On the latest flame 2.2 build, I don't have to spam the play button. Just pause it once and tap play, the song does not preview anymore

Comment 5

3 years ago
I still can't reproduce this. Maybe it's been fixed?
Keywords: qawanted
NO REPRO per this Build: 

Environmental Variables:
Device: Flame 2.5
BuildID: 20151026030217
Gaia: a677ddd3aa3a81058775938bd56008d96dbc78b0
Gecko: 5ca03a00d26823ce91ee0eaa2937bed605bd53c1
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULT: 
When repeatedly press play/pause button to preview ringtone the sound plays and pauses as expected.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Contact: sleedavid
Resolving this issue as WFM.  Please reopen if it occurs again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.