If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

./profile.sh symbolicate doesn't work

RESOLVED DUPLICATE of bug 1085232

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1085232
3 years ago
3 years ago

People

(Reporter: gwagner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I have a enable-debug disable-optimize gecko build and when I try to symbolicate a file on OSX I get

    Adding symbols to profile_1508_b2g.txt and creating profile_1508_b2g.sym ...
    Traceback (most recent call last):
    File "./scripts/profile-symbolicate.py", line 18, in <module>
    url_matcher = re.compile("^(https?:\/\/)(([0-9\da-z\.-]+)\.)?([0-9a-z\.]{2,6})([\/\w \.-]*)*(:[0-9]+)?\/?$")
    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/re.py", line 190, in compile
    return _compile(pattern, flags)
    File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/re.py", line 242, in _compile
    raise error, v # invalid expression
    sre_constants.error: nothing to repeat

Commenting out the 2 lines makes it work.
It feels like you are having the sample problem as Bug 1085232. Could you confirm that, please?
Flags: needinfo?(anygregor)
s/sample/same problem/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085232
(Reporter)

Updated

3 years ago
Flags: needinfo?(anygregor)
You need to log in before you can comment on or make changes to this bug.