bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Midori 2.0][Wi-Fi]The average time of Wi-Fi automatical connection is 2s more than Fire E 1.3 version

RESOLVED WONTFIX

Status

Firefox OS
Wifi
P2
normal
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: sync-1, Assigned: vchang)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(5 attachments)

101.10 KB, application/octet-stream
Details
log
57.55 KB, application/octet-stream
Details
28.53 KB, image/png
Details
109.16 KB, text/plain
Details
92.16 KB, text/plain
Details
(Reporter)

Description

4 years ago
Mozilla Build ID: 20140916000205
 Created an attachment (id=1001961)
 log
 
 DEFECT DESCRIPTION:
 The time of Wi-Fi automatical connection  is 2 seconds more than Fire E 1.3
 
  REPRODUCING PROCEDURES:
 1.Wi-Fi connect to an AP "Cisco01411"
 2.turn off the Wi-Fi
 3.turn on the Wi-Fi and it will connect to the AP "Cisco01411' automatically
 4.repeat the steps above 5 times 
 5.the average time is 5'93-->KO
 6.Fire E 1.3 is 3'976
 note:
 蒋伟,021-31362631
 
 中文:
 1.使用Fire E 2.0 版本测试Wi-Fi自动连接时间,其平均时间是5'93
 2.使用Fire E 1.3 版本测试Wi-Fi自动连接时间,其平均时间是3'976
 
  EXPECTED BEHAVIOUR:
 The time of Wi-Fi automatical connection  is better than Fire E 1.3
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8521072 [details]
LOG_Fire_E_1.3
(Reporter)

Comment 2

4 years ago
Created attachment 8521073 [details]
log
(Reporter)

Comment 3

4 years ago
Created attachment 8521074 [details]
13vs20

Comment 4

4 years ago
[Blocking Requested - why for this release]:this is a block pr, please help check. thanks.
blocking-b2g: --- → 2.0?
(Assignee)

Comment 5

4 years ago
Do these two versions use the same gonk? Like wpa_supplicant/libnetutils... and only difference are the gecko/gaia versions.

Comment 6

4 years ago
No, wpa_supplicant is a newer version.
According to issue steps, we can reproduce on Flame v2.1 and v2.2.
Flame v2.1: 4.7s, 4.8s, 4.8s, 4.9s, 5.0s, 4.7s;  Average time: 4.817s
Flame v2.2: 4.1s, 4.4s, 4.3s, 4.4s, 4.2s, 4.2s;  Average time: 4.267s
See attachment: v2.1_logcat_1703.txt & v2.2_logcat_1709.txt
Reproducing rate: 10/10

FLame2.1 build :
Gaia-Rev        81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3572aa3e6766
Build-ID        20141116001201
Version         34.0

FLame2.2 build :
Gaia-Rev        1dd8ad8f96988afebc9691e1b818fa37aa32c790
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a52bf59965a0
Build-ID        20141116040209
Version         36.0a1
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected

Comment 10

4 years ago
[Blocking Requested - why for this release]:

[Triage] Considering the impact and current phase of 2.0, nom. to 2.1 for consideration.
blocking-b2g: 2.0? → 2.1?
vincent, given the data in comment #7 do you think this is a regression from 1.3 and how do we want to handle this ?
Flags: needinfo?(vchang)
(Assignee)

Comment 12

4 years ago
I don't think this is a regression because it may depend on test environment(air is clean or dirty and AP's behavior) and gonk version(wpa_supplicant, netd, kitcat or Jelly Bean...). The connection time seems acceptable for me. But we can put some log in the code to investigate if there is any  problem in wifi code.
Flags: needinfo?(vchang)
(Assignee)

Updated

4 years ago
Assignee: nobody → vchang
we cannot block on the issue at the minute but vincent please continue to investigate so we are able to fix this issue in 2.2
blocking-b2g: 2.1? → -

Updated

2 years ago
Blocks: 1258639

Comment 14

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.