TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unifiedcomplete/test_swap_protocol.js

RESOLVED FIXED in Thunderbird 36.0

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

({intermittent-failure})

unspecified
Thunderbird 36.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird36 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

17:55:44     INFO -  PROCESS | 20926 | TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unifiedcomplete/test_swap_protocol.js | Looking for 'wikipedia.org', 'Wikipedia (en)' in expected results...
17:55:44     INFO -  PROCESS | 20926 | TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unifiedcomplete/test_swap_protocol.js | Checking against expected 'http://woohoo/', 'title'...
17:55:44     INFO -  PROCESS | 20926 | TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unifiedcomplete/test_swap_protocol.js | Checking against expected 'http://wwwwwwacko/', 'title'...
17:55:44     INFO -  Didn't find the current result ('wikipedia.org', 'Wikipedia (en)') in matches
17:55:44     INFO -      /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unifiedcomplete/head_autocomplete.js:check_autocomplete:179
17:55:44     INFO -      self-hosted:next:883
17:55:44     INFO -      Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:868:23
17:55:44     INFO -      this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:7
17:55:44     INFO -      _do_main@/builds/slave/test/build/tests/xpcshell/head.js:184:5
17:55:44     INFO -      _execute_test@/builds/slave/test/build/tests/xpcshell/head.js:372:5
17:55:44     INFO -      @-e:1:1
17:55:44     INFO -  exiting test
17:55:44     INFO -  Unexpected exception 2147500036
17:55:44     INFO -  undefined
17:55:44     INFO -  exiting test
Posted patch bug1097484.patch (obsolete) — Splinter Review
There is a duplicate entry in wikipedia.xml.
Attachment #8521159 - Flags: review?(mkmelin+mozilla)
The try server result is good but there are other duplicate entries in other xml.
We have to port bug 990799 too.
Comment on attachment 8521159 [details] [diff] [review]
bug1097484.patch

Review of attachment 8521159 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/locales/en-US/searchplugins/wikipedia.xml
@@ +14,5 @@
>  <Url type="text/html"
>       method="GET"
>       template="http://en.wikipedia.org/wiki/Special:Search"
> +     resultdomain="wikipedia.org"
> +     rel="searchform"/>

The "/>" should not work out well at all here... 
I'm surprised it doesn't give an xml parsing error
Attachment #8521159 - Flags: review?(mkmelin+mozilla) → review-
Posted patch Remove an unecessary slash (obsolete) — Splinter Review
That was a horrible copy-and-paste error...
I just confirmed this patch works fine on my local linux.
Attachment #8521159 - Attachment is obsolete: true
Attachment #8521709 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8521709 [details] [diff] [review]
Remove an unecessary slash

Clearing review flag.

This fix is wrong.
I am guessing we should care this failure in mozilla-central..
Attachment #8521709 - Flags: review?(mkmelin+mozilla)
Posted patch test_swap_protocol.diff (obsolete) — Splinter Review
This patch fixes the failure but I think it's a workaround not a proper fix because other tests will fail in the future.

We should move searchplugins into dist/bin/messenger or somewhere else as firefox does?
Attachment #8521709 - Attachment is obsolete: true
Attachment #8521772 - Flags: feedback?(mak77)
As author of bug 1039003, can we just backout the patch from that bug, reopen it and then I'll upload a revised patch for review to that bug?
Flags: needinfo?(hiikezoe)
(In reply to Ian Neal from comment #33)
> As author of bug 1039003, can we just backout the patch from that bug,
> reopen it and then I'll upload a revised patch for review to that bug?

Yes, please!
Flags: needinfo?(hiikezoe)
Attachment #8521772 - Flags: feedback?(mak77)
(In reply to Hiroyuki Ikezoe (:hiro) from comment #34)
> (In reply to Ian Neal from comment #33)
> > As author of bug 1039003, can we just backout the patch from that bug,
> > reopen it and then I'll upload a revised patch for review to that bug?
> 
> Yes, please!

I won't get chance for about another 18 hours, so if you can do something sooner, please do.
Comment on attachment 8521772 [details] [diff] [review]
test_swap_protocol.diff

Review of attachment 8521772 [details] [diff] [review]:
-----------------------------------------------------------------

the decision to copy Firefox behavior on how to package search engines is up to you.

Yes I'm sure in future some tests could still regress, but the coverage we have today is pretty good so I wouldn't expect hundreds of failures or such, the feature is almost stable. Maybe one test every n months could have this issue, it's up to you to figure whether that's acceptable or not, compared to the cost it would have to repackage search engines like you suggested.

I don't think backing out the resultDomain bug for now will change anything, we'd just use the host and tests would still fail... that will likely change in near future, but I have no ETA atm.
Attachment #8521772 - Flags: review+
Carrying over review+.

marco, thank you for your reviewing and advices.
I will manage to take time to move searchplugins into other directory, but now this patch should be checked in.

try server result:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=8e53d7cfa2ed
Assignee: nobody → hiikezoe
Attachment #8521772 - Attachment is obsolete: true
Attachment #8522185 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5dfdebf9cc79
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
You need to log in before you can comment on or make changes to this bug.