Email app is totally broken: cannot sync, cannot switch account

RESOLVED DUPLICATE of bug 1087184

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 1087184
3 years ago
3 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({dogfood, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8521188 [details]
logcat errors

Reproducing on my dogfooding Nexus S, after recent upgrades. I cannot document for sure when this started to fail, but builds from at least last sunday were broken.

STR:
 0. Start email app

Expected:
 Emails syncs, I can switch from default account to another

Actual:
 Spinner never stops, synchronization never happens, switching to another account keeps me on the default account.

There is a bunch of errors in logcat, confere attachment. Build is a userdebug with multilocale enabled. Locale is french.
The error in resolvePeep looks like the 'undisclosed-recipients' issue mentioned in bug 1087184, comment 25. Fixing that bug (which is really fixing an issue with the original pull request for that bug) should resolve the issue, so duping to that bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1087184
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.