Improper auto renaming of Multi-part Extension (like .txt.gz or .tar.gz ot tar.bz2) on Open with actions (Download to temp)

RESOLVED DUPLICATE of bug 366325

Status

()

RESOLVED DUPLICATE of bug 366325
4 years ago
4 years ago

People

(Reporter: Er.Thirumalai, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8521214 [details]
Download Auto Renaming Comparision.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

Use Firefox's open with (download action) more than once for multi-part file extensions like .txt.gz or .tar.gz ot tar.bz2


Actual results:

Using of open with (In downloads actions) for multi-part file extensions (like .txt.gz or .tar.gz ot tar.bz2), the first opening will be proper since there wont be any conflicts.
But, on the consecutive downloads, auto renaming is improper like *.tar-1.gz

But, If I use save action on download instead of open with it saves the file with proper extension i.e *-1.tar.gz which is proper way


Expected results:

Firefox should use the same auto file renaming method (of Save Action) for Open With action as well
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366325
You need to log in before you can comment on or make changes to this bug.