If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame][Contacts] Can't enter the settings page when we tap settings button in contacts list page.

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Paladin, Assigned: Jose Manuel Cantera)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8521261 [details]
Tap_settings_button.MP4

[1.Description]:
[Flame][v2.1&v2.2][Contacts]We can't enter the settings page when we tap settings button many times in contacts list page.
Attachment: logcat_flame_1350.txt and Tap_settings_button.MP4
Occurrence time: 13:50

[2.Testing Steps]: 
1. Open Contacts.
2. Tap settings.
3. Tap Set ICE contact.
3. Set a contact without a phone number as an ICE.
4. The " This contact does not have a phone nember"  alert  page is pop up.
5. Tap the power button to Lock the phone and then tap it again to wake the phone up.
6. Tap "OK" button in  "This contact does not have a phone nember"  alert  page.
7. Into the contacrt list page and tap Settings button.


[3.Expected Result]: 
We can into the settings page.

[4.Actual Result]: 
7. We can't into the settings page when we tap settings button in contacts list page.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        7154f9aa0a69af56c8bd89be0c98d9791449527b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452db1a0c9a0
Build-ID        20141111001201
Version         34.0

FLame 2.2 build:
Gaia-Rev        5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a926116946f8
Build-ID        20141111160205
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141111.191942
FW-Date         Tue Nov 11 19:19:51 EST 2014
Bootloader      L1TC00011880

[6.Reproduction Frequency]: 
Always Recurrence,5/5
(Reporter)

Comment 1

3 years ago
Created attachment 8521265 [details]
logcat_flame_1350.txt
That's a bad edge case that we should fix in 2.2. Do you agree, Jose?
Flags: needinfo?(jmcf)
(Assignee)

Comment 3

3 years ago
Yes, this should be fixed, but I don't know if bug 1093002 is solving this. We will check once that lands but in any case this should be fixed, yes.
Flags: needinfo?(jmcf)
QA-Wanted: can we check Master (2.2) now that but 1093002 has landed to see if it fixed this issue. 
If 2.2 is fixed please verify 2.1 is still 'affected'
Keywords: qawanted

Updated

3 years ago
QA Contact: croesch
This bug still exists in Flame 2.2 KK

Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.2 KK,

Actual Results: The Settings button remains broken after locking and unlocking the phone after setting a contact as an ICE contact that has no phone number.

Repro Rate: 2/2

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141210035415
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Jose - it seems that this is not fixed yet
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(jmcf)
QA Contact: croesch
(Assignee)

Comment 7

3 years ago
Yes, I'm able to reproduce it
Flags: needinfo?(jmcf)
(Reporter)

Comment 8

3 years ago
Created attachment 8543592 [details]
logcat_flame_0317.txt

I was able to reproduce this issue on latest Flame 2.1/2.2
See New Log: logcat_flame_0317.txt
Reproducing rate: 5/5

Flame 2.1:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150103001211
Version         34.0
---------------------
Flame 2.2:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Flags: needinfo?(echang)
Hi Francisco, Could you help with this, we can still reproduce this, thank you.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Gaia::Contacts]
Flags: needinfo?(echang) → needinfo?(francisco)
Hi,

nominating a 2.2 blocker, just to discuss on the triage.

What's happening is that to avoid leaving the app in an intermediate step (like selecting from the list), we listen to events to going on background.

Definitely a weird use case, but something to fix.
blocking-b2g: --- → 2.2?
Flags: needinfo?(francisco)
(Assignee)

Updated

3 years ago
Assignee: nobody → jmcf
(Assignee)

Comment 11

3 years ago
Created attachment 8548019 [details] [review]
GH PR
Attachment #8548019 - Flags: review?(francisco)
triage: broken function. blocker
blocking-b2g: 2.2? → 2.1+
Comment on attachment 8548019 [details] [review]
GH PR

Solution looks good to me, but we have a unit test associated to this change that is failing.
Attachment #8548019 - Flags: review?(francisco) → review-
(Assignee)

Updated

3 years ago
Attachment #8548019 - Flags: review- → review?(francisco)
(Assignee)

Comment 14

3 years ago
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #13)
> Comment on attachment 8548019 [details] [review]
> GH PR
> 
> Solution looks good to me, but we have a unit test associated to this change
> that is failing.

tests fixed, thanks!
Comment on attachment 8548019 [details] [review]
GH PR

Now looking perfect.

I've relaunched a task in gaia-try, please merge once everything is green ... and gaia is open :)

Also please ask for approval for 2.1 and 2.2 branches.

Thanks.
Attachment #8548019 - Flags: review?(francisco) → review+
(Assignee)

Comment 16

3 years ago
https://github.com/mozilla-b2g/gaia/commit/48019f022217eaa2870a632c0491a1f9bb2509dd
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

3 years ago
Comment on attachment 8548019 [details] [review]
GH PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Visibility change in Activities
[User impact] if declined: High, application can have unexpected behaviors  
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Very low risk patch
[String changes made]: none
Attachment #8548019 - Flags: approval-gaia-v2.1?
(Assignee)

Comment 18

3 years ago
Comment on attachment 8548019 [details] [review]
GH PR

see comment requesting approval for v2.1
Attachment #8548019 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Keywords: verifyme

Updated

3 years ago
Attachment #8548019 - Flags: approval-gaia-v2.2?
Attachment #8548019 - Flags: approval-gaia-v2.2+
Attachment #8548019 - Flags: approval-gaia-v2.1?
Attachment #8548019 - Flags: approval-gaia-v2.1+

Updated

3 years ago
status-b2g-master: --- → fixed
v2.2: https://github.com/mozilla-b2g/gaia/commit/c29ed3a4bccbefcd4d67bb8c7dfb13e096a43dd3
v2.1: https://github.com/mozilla-b2g/gaia/commit/404e6053b1d6e7996f42f756a33a786624a8beb2
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S4 (23jan)

Comment 20

3 years ago
v2.1s : https://github.com/mozilla-b2g/gaia/commit/404e6053b1d6e7996f42f756a33a786624a8beb2
status-b2g-v2.1S: --- → fixed

Comment 21

3 years ago
Created attachment 8551071 [details]
verify_video.MP4

This issue has been verified successfully on Flame 2.1/2.2, after tap "OK" button of "This contact does not have a phone nember" page, it will back to "Select contact" page and it could select a correct ICE Contacts.
See attachment:verify_video.MP4

Flame 2.1 build:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150118001331
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.034742
FW-Date         Sun Jan 18 03:47:53 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.035516
FW-Date         Sun Jan 18 03:55:27 EST 2015
Bootloader      L1TC000118D0

Updated

3 years ago
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Issue verified fixed on Flame 3.0

After pressing Okay to confirm no phone number message, user is returned to the select contacts list to chose another ICE contact. No settings icon is present.

Leaving verifyme keyword for 2.1S as I do not have that build available to test.

Device: Flame 3.0 Master
Build ID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::Contacts] → [QAnalyst-Triage?][COM=Gaia::Contacts]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Gaia::Contacts] → +[QAnalyst-Triage+][COM=Gaia::Contacts]
Flags: needinfo?(ktucker)
The problem is verified not happen on latest 2.1s(256m and 512m) build.

Steps:
1. Open Contacts.
2. Tap settings.
3. Tap Set ICE contact.
3. Set a contact without a phone number as an ICE.
4. The " This contact does not have a phone nember"  alert  page is pop up.
5. Tap the power button to Lock the phone and then tap it again to wake the phone up.
6. Tap "OK" button in  "This contact does not have a phone nember"  alert  page.
7. Into the contacrt list page and tap Settings button.

Actual Result: 
7. After tap "OK" button of "This contact does not have a phone nember" page, it will back to "Select contact" page and it could select a correct ICE Contacts.

Fail rate:0/5

2.1s(256m) version:
Build ID               20150209001232
Gaia Revision          bca70e96979fbd714012dc442a92b9fa156f63f7
Gaia Date              2015-02-03 00:37:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/afac5ac46ff6
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.035424
Firmware Date          Mon Feb  9 03:54:36 EST 2015

2.1s(512m) version:
Build ID               20150209001232
Gaia Revision          bca70e96979fbd714012dc442a92b9fa156f63f7
Gaia Date              2015-02-03 00:37:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/afac5ac46ff6
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  93
Firmware Date          Thu Jan 22 15:21:20 CST 2015
QA Whiteboard: +[QAnalyst-Triage+][COM=Gaia::Contacts] → +[QAnalyst-Triage+][COM=Gaia::Contacts][MGSEI-Triage+]
status-b2g-v2.1S: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.