If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[XUL] .style is not accessible or enumeratable in XUL

RESOLVED DUPLICATE of bug 7639

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 7639
16 years ago
16 years ago

People

(Reporter: Andy Edmonds, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Reproducible: Always
Steps to Reproduce:
Dump, alert, or otherwise access .style in XUL.  Test case shows access .style 
and "for i in" style asserting.

Actual Results:  Asserts.
Expected Results:  Style property names and values are enumerated.

Tested in w2k 9.4 and 9.5+ Gecko/20011011
(Reporter)

Comment 1

16 years ago
Created attachment 57484 [details]
Two buttons for accessing .style and "for i in style"

Comment 2

16 years ago
Dup.

*** This bug has been marked as a duplicate of 7639 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.