Error using usePrivateBrowsing in gaia

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: kgrandon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I was playing around earlier, and I get this error when setting the private browsing attribute in the system app:

W/Browser ( 1352): [JavaScript Warning: "Only internal code is allowed to set the usePrivateBrowsing attribute" {file: "chrome://global/content/BrowserElementChild.js" line: 63}]
(Reporter)

Comment 1

3 years ago
Fabrice - do you want to look into this?
Flags: needinfo?(fabrice)
Well, what did you do exactly? We have tests at https://mxr.mozilla.org/mozilla-central/source/dom/browser-element/mochitest/ (test_browserElement_inproc_PrivateBrowsing.html and test_browserElement_oop_PrivateBrowsing.html) that don't seem to hit that error...
Flags: needinfo?(fabrice)
(Reporter)

Comment 3

3 years ago
I have a patch now in bug 1081731. After applying that, I see these errors in logcat.
I can't repro with your patch. Do you have explicit STR? I opened private browsing windows both from the context menu and from the browser frame menu with no problem.
(Reporter)

Comment 5

3 years ago
(In reply to Fabrice Desré [:fabrice] from comment #4)
> I can't repro with your patch. Do you have explicit STR? I opened private
> browsing windows both from the context menu and from the browser frame menu
> with no problem.

My STR is:
1 - Load the patch from bug 1081731
2 - Load any website
3 - Click the context menu -> new private window

As soon as I do this I see the error in logcat. Note: the error logs as it's in the "Browser" process, and not gecko or the system app. There is no visual impact to the user, it only shows up in logcat.
Weird, I definitely can't reproduce.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.