Some MathML reftests fail when using D2D 1.1 Canvas

RESOLVED FIXED in mozilla36

Status

()

Core
Graphics
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bas, Assigned: bas)

Tracking

unspecified
mozilla36
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
These tests are currently marked fuzzy when Canvas & Content backends differ, but not when they don't. It looks like they're just as fuzzy when the content and canvas backends are identical.
(Assignee)

Comment 1

4 years ago
Created attachment 8521371 [details] [diff] [review]
Mark tests fuzzy even when using the same canvas and content backends
Attachment #8521371 - Flags: review?(jmuizelaar)
Comment on attachment 8521371 [details] [diff] [review]
Mark tests fuzzy even when using the same canvas and content backends

I can't remember the details, but I fuzzed in this way because the tests only failed on some windows machines and the difference seemed to be contentSameGfxBackendAsCanvas (canvas is used to render and compare reftests, hence its potential relevance). Anyway, I don't think it's a big deal to extend the fuzz. I do wonder if the d2d version used for canvas is different to the d2d version used for content in this case though, and maybe that's the cause of the difference.
Attachment #8521371 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/31f0acf5b7bc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.