If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in mozilla::layers::LayerTransactionChild::IPCOpen() const

RESOLVED FIXED in Firefox 36, Firefox OS v2.1

Status

()

Core
Graphics: Layers
--
critical
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: milan)

Tracking

({crash})

Trunk
mozilla36
All
Android
crash
Points:
---

Firefox Tracking Flags

(firefox35 wontfix, firefox36 fixed, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
I just got this crash with a recent trunk build on the Flame (188 base image), while switching browser windows.

This bug was filed from the Socorro interface and is 
report bp-37ae9972-e5e2-475d-a964-dbf302141112.
=============================================================
0 	libxul.so 	mozilla::layers::LayerTransactionChild::IPCOpen() const 	/builds/slave/b2g_m-cen_flm-kk_eng_ntly-0000/build/objdir-gecko/dist/include/mozilla/layers/LayerTransactionChild.h:43
1 	libxul.so 	mozilla::layers::ShadowLayerForwarder::IsSameProcess() const 	gfx/layers/ipc/ShadowLayers.cpp
2 	libxul.so 	mozilla::layers::ShadowLayerForwarder::EndTransaction(nsTArray<mozilla::layers::EditReply>*, nsIntRegion const&, unsigned long long, bool, unsigned int, bool, mozilla::TimeStamp const&, bool*) 	gfx/layers/ipc/ShadowLayers.cpp
3 	libxul.so 	mozilla::layers::ClientLayerManager::ForwardTransaction(bool) 	gfx/layers/client/ClientLayerManager.cpp
4 	libxul.so 	mozilla::layers::ClientLayerManager::EndTransaction(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) 	gfx/layers/client/ClientLayerManager.cpp
5 	libxul.so 	nsDisplayList::PaintRoot(nsDisplayListBuilder*, nsRenderingContext*, unsigned int) 	layout/base/nsDisplayList.cpp
6 	libxul.so 	nsLayoutUtils::PaintFrame(nsRenderingContext*, nsIFrame*, nsRegion const&, unsigned int, unsigned int) 	layout/base/nsLayoutUtils.cpp
7 	libxul.so 	PresShell::Paint(nsView*, nsRegion const&, unsigned int) 	layout/base/nsPresShell.cpp
8 	libxul.so 	nsViewManager::ProcessPendingUpdatesPaint(nsIWidget*) 	view/nsViewManager.cpp
9 	libxul.so 	nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) 	view/nsViewManager.cpp
10 	libxul.so 	nsRefreshDriver::Tick(long long, mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp
(Assignee)

Comment 1

3 years ago
Created attachment 8525546 [details] [diff] [review]
One more place to check for valid shadow manager. r=sotaro

Speculative patch.
Attachment #8525546 - Flags: review?(sotaro.ikeda.g)
Comment on attachment 8525546 [details] [diff] [review]
One more place to check for valid shadow manager. r=sotaro

good catch!
Attachment #8525546 - Flags: review?(sotaro.ikeda.g) → review+
(Assignee)

Comment 3

3 years ago
For checkin-needed: trivial change (null pointer check before calling a function on it), no try push, let me know if I should do one anyway.
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/565121755b11
Assignee: nobody → milan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/565121755b11
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36

Comment 6

3 years ago
Comment on attachment 8525546 [details] [diff] [review]
One more place to check for valid shadow manager. r=sotaro

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1124551
User impact if declined: Crash happens
Testing completed: Run Monkey test
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: None.
Attachment #8525546 - Flags: approval-mozilla-b2g34?

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected

Updated

3 years ago
Attachment #8525546 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f50ac547c34d
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: --- → fixed
status-firefox35: --- → wontfix
status-firefox36: --- → fixed

Comment 8

3 years ago
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/f50ac547c34d
status-b2g-v2.1S: affected → fixed
Blocks: 1124551
You need to log in before you can comment on or make changes to this bug.