Tab bar switches rapidly between being scrollable and not being scrollable for certain amount of tabs

RESOLVED DUPLICATE of bug 1096542

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1096542
3 years ago
3 years ago

People

(Reporter: Lucas Werkmeister, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141110194510

Steps to reproduce:

- Have a screen that is 1920 pixels wide
- Be on Linux (so that the tab bar is not in the title bar, and the maximize / close buttons don’t take space away from it)
- Create a fresh profile
- Maximize the browser window
- Customize: Remove the “New Tab” button from the tab bar
- Create 3 new tabs and pin them (close the start tab)
- Create 13 new tabs
- Switch back to the first tab by pressing Alt+1 – browser might hang for about a second here

I have also observed the behavior in other window sizes (unmaximized) and other tab counts, but if your screen is 1920 pixels wide and you are on Linux, then the above steps will probably be easiest and most reliable to reproduce. In general, it appears to happen when the tabs will “soon” no longer fit into the tab bar.


Actual results:

The tab bar flickers rapidly between being scrollable and not being scrollable, jerking the tabs around. If one of the pinned tabs is selected, the pinned tabs will jerk around as well; if one of the unpinned tabs is selected, only the unpinned tabs move.

The flickering does not happen if the last tab is selected. (As a consequence, while creating the tabs, it will also not start until you select a different tab.)

As best I can tell, while flickering the browser seems to use 100% of one CPU core.


Expected results:

The tab bar should either be scrollable or not, but stay in that state.
(Reporter)

Comment 1

3 years ago
Should I attach a screencast? I’m afraid the file would have to be rather large, since I can only *reliably* reproduce the problem in 1080p.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096542
(Reporter)

Comment 3

3 years ago
Oh, sorry about the duplicate – I had searched for a few verbs, but “jitter” wasn’t one of them :)
You need to log in before you can comment on or make changes to this bug.