Intermittent test_mozaudiochannel.html | application crashed [@ CoreAudio + 0x1c7fe]

RESOLVED FIXED in Firefox 38

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: cbook, Assigned: RyanVM)

Tracking

({crash, intermittent-failure})

Trunk
mozilla40
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 wontfix, firefox38 fixed, firefox39 fixed, firefox40 fixed, firefox-esr31 unaffected, b2g-v2.2 fixed, b2g-master fixed)

Details

()

Reporter

Description

5 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-3

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=3812968&repo=mozilla-inbound

07:35:05 WARNING - PROCESS-CRASH | /tests/dom/media/webaudio/test/test_mozaudiochannel.html | application crashed [@ CoreAudio + 0x1c7fe]
07:35:05 INFO - Crash dump filename: /var/folders/Z3/Z3leZCmMFDq0PUsQ7ocDF++++-k/-Tmp-/tmpr0tH6Q.mozrunner/minidumps/36C26AB9-DD6C-417A-97BC-A80AA479862B.dmp
07:35:05 INFO - Operating system: Mac OS X
07:35:05 INFO - 10.6.8 10K549
07:35:05 INFO - CPU: amd64
07:35:05 INFO - family 6 model 23 stepping 10
07:35:05 INFO - 2 CPUs
07:35:05 INFO - Crash reason: EXC_BAD_ACCESS / 0x0000000d
07:35:05 INFO - Crash address: 0x0
07:35:05 INFO - Thread 65 (crashed)
07:35:05 INFO - 0 CoreAudio + 0x1c7fe
07:35:05 INFO - rbx = 0x000000012d9c0c00 r12 = 0x000000012d9c0c00
07:35:05 INFO - r13 = 0x0000000000000000 r14 = 0x000000011e55ac00
07:35:05 INFO - r15 = 0x000000011d512c2c rip = 0x00007fff869047fe
07:35:05 INFO - rsp = 0x000000014b051560 rbp = 0x000000014b051560
07:35:05 INFO - Found by: given as instruction pointer in context
07:35:05 INFO - 1 CoreAudio + 0x1c762
07:35:05 INFO - rip = 0x00007fff86904763 rsp = 0x000000014b051570
07:35:05 INFO - rbp = 0x000000014b0515b0
07:35:05 INFO - Found by: stack scanning
07:35:05 INFO - 2 CoreAudio + 0x17b78
07:35:05 INFO - rip = 0x00007fff868ffb79 rsp = 0x000000014b0515c0
07:35:05 INFO - rbp = 0x000000014b051620
07:35:05 INFO - Found by: stack scanning
07:35:05 INFO - 3 CoreAudio + 0x1b44b
07:35:05 INFO - rip = 0x00007fff8690344c rsp = 0x000000014b0515d0
07:35:05 INFO - rbp = 0x000000014b051620
07:35:05 INFO - Found by: stack scanning
07:35:05 INFO - 4 CoreAudio + 0x1797f
07:35:05 INFO - rip = 0x00007fff868ff980 rsp = 0x000000014b051630
07:35:05 INFO - rbp = 0x000000014b0516a0
07:35:05 INFO - Found by: stack scanning
07:35:05 INFO - 5 CoreAudio + 0x18298
07:35:05 INFO - rip = 0x00007fff86900299 rsp = 0x000000014b051640
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 2

5 years ago
I'm sure it's a total coincidence that this started after bug 1073615 re-landed.
Blocks: 1073615
This might be caused by the general 10.6 flakiness when a lot of streams are opened at the same time.

There is logic in the MSG to use a normal thread if the audio stack fails to give it an audio thread.

To start debugging this, I think it's best to printf() the number of streams (in cubeb_audiounit.c, context->active_streams), see if it's too high.
Comment hidden (Legacy TBPL/Treeherder Robot)
> To start debugging this, I think it's best to printf() the number of streams
> (in cubeb_audiounit.c, context->active_streams), see if it's too high.

I guess that, with the current patch I proposed for bug 1073615, we can have 1 stream per each audioChannel. In total 7 streams. it it too high?
Flags: needinfo?(padenot)
Considering a bunch of tests are running at the same time, that's likely. Then again, cubeb should enfore that no more than 8 streams are running at the same time. I'm not really sure what's up, but it looks like 10.6 has issues when creating/destroying a bunch of audio streams in a quick succession.
Flags: needinfo?(padenot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 136

4 years ago
https://hg.mozilla.org/mozilla-central/rev/5930ff084231

Going to go ahead and resolve this under the assumption that this will be the last we think of this until after 10.6 is shut off permanently.
Assignee: nobody → ryanvm
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.