View-Page-Info doesn't always work for XSLT transformed docs

VERIFIED FIXED in mozilla1.0.1

Status

SeaMonkey
Page Info
P4
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Mike Schiraldi, Assigned: peterv)

Tracking

Trunk
mozilla1.0.1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I'm not sure which layer is causing the problem, but if you go the that URL and
view the source, you see:

<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="test.xsl"?>
<!-- this is a test document -->
<document>
<!-- test comment -->
<x name="x">x</x>
<y name="y">y</y>
<z name="z">z</z>

<abc>
<def>def</def>
</abc>
</document>

Which is not the source.

And if you view Page Info, it's all undefined.
(Assignee)

Comment 1

17 years ago
View source always shows the source of the page as it comes of the network, so
the view source works just fine. I could swear we had a bug like this before,
I'll let someone with a better memory mention it.
The Page info stuff is odd, we should try to fix that.
Assignee: kvisco → peterv
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P4
Hardware: PC → All
Summary: View-source and View-Page-Info don't always work for XML docs → View-Page-Info doesn't always work for XSLT transformed docs
Target Milestone: --- → mozilla1.0
the ability to view the output from the transformation is covered by bug 69912
This looks like it's mostly fixed by bug 52730, at least as far as Page Info
goes. It still says unknown for the mime type of the document, but it would just
seem that document.contentType is unset in this case. Is that a bug?
it should be pretty easy to set document.contentType in the new output-handlers 
once we have those
Depends on: 96647

Comment 5

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
(Assignee)

Comment 6

17 years ago
Fixed by the patch for bug 96647.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
Component: XSLT → Page Info
QA Contact: kvisco → pmac

Comment 7

17 years ago
I'm reopening this bug because if you view Page Info, it's all undefined
(windows 98: commercial trunk: 2002-01-30-08-trunk). Screenshot is coming...

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

17 years ago
Created attachment 67148 [details]
page info dialog shows 'underfined'
in that case the commercial trunk has the old version of the dialog. Works great
in this build of mozilla, 2002011803, except that it still doesn't know the mime
type.  Based on what sicking said, that's another bug.
WFM win98se build 2002030803
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
Verified on all platforms both on branch build (2002-04-29-09-1.0.0) and
commercial trunk (2002-04-29-08-TRUNK).
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.