Standalone rooms needs Logo, ToS and additional styling

RESOLVED FIXED in Firefox 35

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: standard8, Unassigned)

Tracking

unspecified
mozilla36
Points:
5
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox35 fixed, firefox36 fixed)

Details

(Whiteboard: [rooms])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
We need to complete the layout of the standalone rooms views:

- Add the Logo
- Add the ToS links and Mozilla Logo
- Additional styling to make them work nicer, e.g. black background, and better resizing.
(Reporter)

Comment 1

4 years ago
Darrin: Have we got the logo already? How do we get the standalone one for rooms?
Flags: needinfo?(dhenein)
Assignee: nobody → nperriault
Points: --- → 5
Whiteboard: tech-debt
Whiteboard: tech-debt
Created attachment 8522415 [details] [diff] [review]
Part 1: Loop standalone styling enhancements.

Ready for review.

Part 2 will (try to) address remaining responsive design issues.
Attachment #8522415 - Flags: review?(standard8)
Created attachment 8522419 [details]
Screenshot of Standalone Room UI, Part 1
Created attachment 8522421 [details] [diff] [review]
Part 1: Loop standalone styling enhancements.

Removed dead code.
Attachment #8522415 - Attachment is obsolete: true
Attachment #8522415 - Flags: review?(standard8)
Attachment #8522421 - Flags: review?(standard8)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8522421 [details] [diff] [review]
Part 1: Loop standalone styling enhancements.

Review of attachment 8522421 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the css issue fixed or explained.

::: browser/components/loop/content/shared/css/conversation.css
@@ +718,5 @@
> +  background-position: 10px;
> +  background-repeat: no-repeat;
> +}
> +
> +.room-conversation-wrapper header h1 .logo {

This style appears to be unused (some of its a duplicate of the previous one, so I think we can safely drop this).
Attachment #8522421 - Flags: review?(standard8) → review+
(Reporter)

Comment 6

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/100301b84f5f

Dropping need-info as we've used the Firefox logo, which we understand is the correct one.

Marking as leave-open for the responsive design/general css improvements.
Iteration: --- → 36.3
Flags: needinfo?(dhenein)
Keywords: leave-open
Target Milestone: --- → mozilla36
I'm not sure if this is the best bug to handle this, but the standalone is currently missing a "rejoin" button.  Doing a needinfo to Mark in case he is planning to do that on a different bug or wants me to file a new bug.
Flags: needinfo?(standard8)
(Reporter)

Comment 10

4 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #9)
> I'm not sure if this is the best bug to handle this, but the standalone is
> currently missing a "rejoin" button.  Doing a needinfo to Mark in case he is
> planning to do that on a different bug or wants me to file a new bug.

That would be bug 1100378.
Flags: needinfo?(standard8)
backlog: --- → Fx35+
Priority: -- → P1
Whiteboard: [rooms]
Filed bug 1104051 for remaining work here, so this can be marked as fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Keywords: leave-open
Bug 1104051 landed under this bug number, FWIW.
status-firefox35: --- → fixed
status-firefox36: --- → fixed
Flags: qe-verify-
Comment on attachment 8522421 [details] [diff] [review]
Part 1: Loop standalone styling enhancements.

Approval Request Comment
[Feature/regressing bug #]: Rooms
[User impact if declined]: Merges (touches shared files, though it's standalone-only)

[Describe test coverage new/current, TBPL]: Standalone, NPOTB

[Risks and why]: virtually no risk (standalone changes to shared file)

[String/UUID change made/needed]: none
Attachment #8522421 - Flags: approval-mozilla-beta?
Attachment #8522421 - Flags: approval-mozilla-aurora?
Attachment #8522421 - Flags: approval-mozilla-beta?
Attachment #8522421 - Flags: approval-mozilla-beta+
Attachment #8522421 - Flags: approval-mozilla-aurora?
Attachment #8522421 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.