If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Posted data keeps reposting

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
--
minor
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Steven Lake, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)
BuildID:    2001101117

Ok, here's a quirk I see in Mozilla that I don't in Netscape.  If you're working 
a form, say like how we access our Oracle DB via netscape here at work, when 
you're in the notes window and you back up to see previous notes, or you back up 
to any page that was previously sent with a "POST" operation, it resends that 
data or tries to repost it when it goes back to that page.  Netscape I've 
noticed doesn't do that.  When you click back, it just shows results of the last 
post operation without reposting the same data.  Can we get that into Mozilla 
somehow?  It's getting annoying to have to keep telling it not to repost the 
data when backing up in a window.

Reproducible: Always
Steps to Reproduce:
1.  Press submit on any form.
2.  Try to back up.
3.  Gives "Info has expired, would you like to resend this data?" or something 
like that.

Actual Results:  Reposts the same data I just submitted.

Expected Results:  Just backed up to the previously submitted page(s) and shown 
the results from the post without actually reposting the form data.
Reporter: 
Can you try it again with a recent nightly build ?
It works for me with win2k build 20011111.. 
(URL: http://babelfish.altavista.com/tr)

Comment 2

16 years ago
->form submission
Assignee: asa → alexsavulov
Component: Browser-General → Form Submission
QA Contact: doronr → vladimire
This is not form sub.  Session history.
Assignee: alexsavulov → radha
Component: Form Submission → History: Session
QA Contact: vladimire → claudius
wfm -> marking worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.